cancel
Showing results for 
Search instead for 
Did you mean: 

ICX Stack LAG Issues

Dr_Kosmos
New Contributor

We have an issues with a ICX 7550 Stacks where traffic seems to be discarded.

The stack have a Firewall connected with a LAG with one connection per Stack Unit.We also have a LAG from this stack to another ICX 7550 Stack which acts as dist switches for all the access switches.
Traffic in the primary stack that flows through the LACP port to the secondary unit seems to be discarded and we encounter intermittent traffic flow.
To solve this issue we've been forced to disable the ports on the secondary unit. 

The issue also occurs when the firewall is connected only using one port to the primary unit. And the dist switches are connected to both the primary and secondary units. So when traffic flows through the secondary unit it seems to disappear.

We've setup both the stacks with 2x40Gig DAC- Cables.

Stack config

ver 09.0.10h_cd2T241
!
stack unit 1
unit-name sw01-1
module 1 icx7550-24f-port-management-module
module 2 icx7550-100g-2port-200g-module
priority 255
stack-trunk ethernet 1/2/1 to 1/2/2
stack unit 2
unit-name sw01-2
module 1 icx7550-24f-port-management-module
module 2 icx7550-100g-2port-200g-module
priority 240
stack-trunk ethernet 2/2/1 to 2/2/2
stack enable
stack mac d4bd.4f36.33b0
!
hitless-failover enable
!

Lag Configs

lag FW-LAG1 dynamic id 1
ports ethe 1/1/15 ethe 2/1/15
port-name FW1-X1 ethernet 1/1/15
port-name FW1-X2 ethernet 2/1/15
disable ethe 2/1/15

!
lag EDS dynamic id 4
ports ethe 1/1/23 ethe 2/1/23
port-name LACP_SW ethernet 1/1/23
port-name LACP_SW ethernet 2/1/23
disable ethe 2/1/23
!

All help is appreciated.
We belive that the stack configuration is correct and we suspect that there might be some other, maybe hardware related issues with stack unit number two.

We've tried and replaced the DAC Cables. 
Tried firmware 8.0.95 now runs 9.0.10h

 

 

3 REPLIES 3

Mayank
RUCKUS Team Member

Hi Dr_Kosmos,

Thank you for reaching us.

I have a question for you here :

Is this a new setup or existing setup ?

Was there any recent software/config/network changes that trigger the issue?

The SFPs are Ruckus branded?

Is it possible to test with a static lag?

Could you please make sure the lag settings on both sides of the connection are the same (both sides dynamic or static, same speed)

Please share the below logs

show int e x/x/x (this command for all the lag interfaces involved in the issue)
show media eth x/x/x (this command for all the lag interfaces involved in the issue)
show media validation eth x/x/x (the ports being used for the Dynamic LAG)
show inter lag <id>
show lag
show lag brief
show lag statistics

Also enable optical monitor and then provide the followin output from the ports in use for the LAG:

(config)#optical-monitor
(config)#show optic x/x/x (the ports in use for the LAG)

Thanks

Chandini
RUCKUS Team Member

Hi Dr_Kosmos

Thank you for reaching us

  1. Could you help us with below outputs
    • show version
    • show stack detail
    • show stack connection
    • show run vlan
  2. Is the downlink directly connected switches able to communicate correctly to this stack ? and is the problem noticed only from unit 2 in the stack to firewall only ? Could you brief us a little more about this problem ?
  3. Could you please let us know if you have tried having connection only from active unit or member 1 and disabled connection from unit 2 in the stack and seeing any issue ? 

Thanks 

inphobia
New Contributor II

it seems i failed to see the firewall brand you're using. going by the ifdescr it might be fortinet? they had an issue in older fortios versions where the secondary lacp link failed to form a bond. was kinda hard to troubleshoot too.