cancel
Showing results for 
Search instead for 
Did you mean: 

Slow performance on Ruckus ICX 8200 switches

SopracoIT
New Contributor

Hi All,

Last year we installed new switches. Previously we worked with HP 1950 switches. During the network project we installed new Ruckus 8200 switches. Since then we have performance issues with our ERP program called CSB. To clarify CSB is a client server connection using SQL server and ODBC driver on the client side.

The problem we are having is that CSB is running very slow on the 8200 switches when being connected to a docking station. We have tested with several docking stations. Here are some setups we have tested:

  • HP probook 450 G8 with a HP USB-C dock G4 > slow performance
  • HP probook 450 G8 with a Lenovo USB-C dock > slow performance
  • HP probook 450 G8 with a HP Thunderbolt USB-C dock > slow performance
  • HP elitebook 650 G9 with a HP USB-C dock G4 > slow performance
  • HP elitebook 650 G9 with a Lenovo USB-C dock > slow performance
  • HP elitebook 650 G9 with a HP Thunderbolt USB-C dock > good performance
  • HP probook 650 G4 with a HP ultraslim dock > good performance

HP elitebooks are only used by IT, the majority has a probook 450 G8 or a probook 650 G4. We recently bought new laptops. HP probook 450 G10 and they also have the slow performance. What we noticed is that all laptops are using a Realtek driver for the network and the elitebook are using a Intel driver with the HP thunderbolt driver. So we were thinking that there was a problem with the Realtek drivers.

Countless updates did not resolve the issue. I also did several whireshark sessions just to explore what was going on and what we did notice is that the TDS protocol is taking a very long time.

One more thing is once we connect a unmanaged switch, a usb to ethernet adapter, a physical telephone between docking and switch everything is running fast again. So we started investigating and the flow control feature has effect it seems. If we disable flow control on the HP switches, everything is slow again. What I read is that on Ruckus 8200 switches flow control is on by default. We have tested with several flow control settings but none of them make a difference. Also enabling the symmetrical flow control setting does not resolve the issue.

Here are some outputs of whiresharks. I sorted the whole whireshark so you can see what takes the longest to process. Just to give you an image. We start CSB and then open the GPM editor (to edit labels) and that takes normally around 6 seconds to open.

This output is done on our old HP switches:

SopracoIT_0-1715677446735.png

You can see that the TDS protocol is taking around 4.5 seconds to process

 

This is the output done on our new Ruckus 8200 switches:

SopracoIT_1-1715677446737.png

You can clearly see that the same process is taking 5-6 times longer than usual. This has effect on all things done in CSB.

 

As a test we received a Ruckus 7150 switch. We connected the switch the same way as the 8200 switches in our network. When connected to a 7150 switch all problems are resolved. All setups as mentioned above have good performance. The GPM editor opens in around 6 seconds. The configuration of the 7150 and the 8200 are the same which is pretty basic.

So from all testing we think the issue sits with our 8200 switches. We have already done updates to the RDR10010b firmware. But that does not resolve the issue.

We hope by this way we can finally find a solution for this very annoying problem.

 

Thanks in Advance!

4 REPLIES 4

Chandini
RUCKUS Team Member

 Hi SopracoIT

Thanks for reaching us.

  • Could you help me with firmware version running on 7150 switch ?
  • Also would you be able to share running configuration from both switches on the portal ?

If any concerns with regard to sharing running configuration in portal I would suggest to log a case with us using below link. 

Thanks 

SopracoIT
New Contributor

Hi Chandini,

the firmware running on 7150 switch is SPS08095m

here are the running configs of both types of switches:

7150:

SSH@SW-RUCKUS-TEMP#show run
Current configuration:
!
ver 08.0.95mT211
!
stack unit 1
module 1 icx7150-24-port-management-module
module 2 icx7150-2-copper-port-2g-module
module 3 icx7150-4-sfp-plus-port-40g-module
stack-port 1/3/1
stack-port 1/3/3
!
!
!
lag CORE dynamic id 1
ports ethe 1/3/4
!
!
!
default-vlan-id 3999
!
vlan 1 name VLID1_LAN by port
tagged ethe 1/2/1 lag 1
untagged ethe 1/1/1 to 1/1/24
no spanning-tree
!
vlan 2 name VLID2_TELENET-FIBERNET-COAX by port
tagged ethe 1/2/1 lag 1
no spanning-tree
!
vlan 3 name VLID3_TELENET-FIBER by port
tagged ethe 1/2/1 lag 1
no spanning-tree
!
vlan 4 name VLID4_GUEST by port
tagged ethe 1/2/1 lag 1
no spanning-tree
!
vlan 5 name VLID5_CAMERA by port
tagged ethe 1/2/1 lag 1
no spanning-tree
!
vlan 6 name VLID6_ADMINISTRATIE by port
tagged ethe 1/2/1 lag 1
no spanning-tree
!
vlan 8 name VLID8_PRODUKTIE by port
tagged ethe 1/2/1 lag 1
no spanning-tree
!
vlan 10 name VLID10_VOICE by port
tagged ethe 1/1/1 to 1/1/24 ethe 1/2/1 lag 1
no spanning-tree
!
vlan 11 name VLID11_BIZERBA by port
tagged ethe 1/2/1 lag 1
no spanning-tree
!
vlan 12 name VLID12_Technische-Vlan by port
tagged ethe 1/2/1 lag 1
no spanning-tree
!
vlan 13 name VLID13_Telenet-Sip by port
tagged ethe 1/2/1 lag 1
no spanning-tree
!
vlan 14 name VLID14_vMotion by port
tagged ethe 1/2/1 lag 1
no spanning-tree
!
vlan 15 name VLID15_DMZ by port
tagged ethe 1/2/1 lag 1
no spanning-tree
!
vlan 20 name VLID20_CONSULTANT-VLAN by port
tagged ethe 1/2/1 lag 1
no spanning-tree
!
vlan 98 name VLID98_IPVPN by port
tagged ethe 1/2/1 lag 1
no spanning-tree
!
vlan 99 name VLID99_MGMT by port
tagged ethe 1/2/1 lag 1
no spanning-tree
management-vlan
default-gateway 192.168.199.1 1
!
!
!
!
!
!
!
!
vlan 3999 name DEFAULT-VLAN by port
no spanning-tree
!
!
!
mstp scope all
mstp instance 0 vlan 1 to 6
mstp instance 0 vlan 8
mstp instance 0 vlan 10 to 15
mstp instance 0 vlan 20
mstp instance 0 vlan 98 to 99
mstp instance 0 vlan 3999
mstp admin-edge-port ethe 1/1/1 to 1/1/24
mstp start
!
!
!
!
errdisable recovery cause loop-detect
errdisable recovery cause bpduguard
errdisable recovery interval 30
aaa authentication web-server default local
aaa authentication login default local
console timeout 240
enable password-display
enable super-user-password 8 $1$3QKsJ7ZL$/p6IFGQttknTKUzPNlHQY0
enable port-config-password 8 $1$vdRclXPE$AUD0vJzPgzMuabJoeKjhJ.
enable read-only-password 8 $1$g8n//7uw$xRSlYZbx8j.8Xj8sDrD/L0
enable aaa console
hostname SW-RUCKUS-TEMP
ip address 192.168.199.16 255.255.255.0
!
no telnet server
username super password 8 $1$I9VuIJRW$2o1w5BbxkfJo78GpWwaBX/
username admin password 8 $1$sEPEUQTB$HTgIwSTf4YvYFTYHBkK0m.
!
!
snmp-server contact support@vanroey.be
snmp-server location "SopracoNV - Geel"
snmp-server group Ncentral v3 priv read all write all notify all
snmp-server user Ncentral Ncentral v3 encrypted auth sha e474cbbc4bfc3b31f15fdf003f450d5ad1e10758 priv encrypted aes 65a0f499727497e199a992388f3bdc90
!
!
clock summer-time
clock timezone gmt GMT+01
!
!
ntp
server 84.199.86.248
server 81.82.227.219
!
!
no web-management http
banner motd ^C
+-----------------+ WARNING +------------------+^C
. .^C
.Access to this system is limited to authorized.^C
. users and for official purposes only. .^C
. .^C
. Your activities will be logged and abuse .^C
. will be reported! .^C
. .^C
. __ __ _____ .^C
. \ \ / / | __ \ .^C
. \ \ / /_ _ _ __ | |__) |___ ___ _ _ .^C
. \ \/ / _` | '_ \ | _ // _ \ / _ \ | | | .^C
. \ / (_| | | | | | | \ \ (_) | __/ |_| | .^C
. \/ \__,_|_| |_| |_| \_\___/ \___|\__, | .^C
. __/ | .^C
. |___/ .^C
. .^C
+-----------------+ WARNING +------------------+^C
^C
!
!
!
manager registrar
manager active-list 192.168.168.19
!
manager port-list 987
!
!
interface ethernet 1/1/1
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/2
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/3
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/4
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/5
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/6
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/7
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/8
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/9
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/10
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/11
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/12
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/13
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/14
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/15
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/16
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/17
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/18
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/19
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/20
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/21
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/22
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/23
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/1/24
loop-detection
voice-vlan 10
broadcast limit 300
multicast limit 300
stp-bpdu-guard
trust dscp
!
interface ethernet 1/2/1
disable
voice-vlan 10
broadcast limit 300
multicast limit 300
trust dscp
!
interface lag 1
voice-vlan 10
broadcast limit 300
multicast limit 300
trust dscp
!
!
!
!
!
!
!
!
!
ip ssh idle-time 240

 

 

8200:

SSH@KALVERSTAL#show run
Current configuration:
!
ver 10.0.10b_cd1T253
!
stack unit 1
module 1 icx8200-24p-port-management-module
module 2 icx8200-4-sfp-plus-port-100g-module
stack-port ethernet 1/2/1
stack-port ethernet 1/2/3
!
!
!

!
!
!
lag CORE-KALVERSTAL dynamic id 1
ports ethe 1/2/2 ethe 1/2/4
port-name CORE-KALVERSTAL ethernet 1/2/2
port-name CORE-KALVERSTAL ethernet 1/2/4
!
!
default-vlan-id 3999
!
vlan 1 name VLID1_LAN by port
tagged lag 1
untagged ethe 1/1/4 to 1/1/7 ethe 1/1/9 to 1/1/18 ethe 1/1/20 to 1/1/24
!
vlan 2 name VLID2_TELENET-FIBERNET-COAX by port
tagged lag 1
!
vlan 3 name VLID3_TELENET-FIBER by port
tagged lag 1
!
vlan 4 name VLID4_GUEST by port
tagged lag 1
!
vlan 5 name VLID5_CAMERA by port
tagged lag 1
untagged ethe 1/1/1 to 1/1/3
!
vlan 6 name VLID6_ADMINISTRATIE by port
tagged lag 1
!
vlan 8 name VLID8_PRODUKTIE by port
tagged lag 1
!
vlan 10 name VLID10_VOICE by port
tagged ethe 1/1/20 lag 1
untagged ethe 1/1/8 ethe 1/1/19
!
vlan 11 name VLID11_BIZERBA by port
tagged lag 1
!
vlan 12 name VLID12_Technische-Vlan by port
tagged lag 1
!
vlan 13 name VLID13_Telenet-Sip by port
tagged lag 1
!
vlan 14 name VLID14_vMotion by port
tagged lag 1
!
vlan 15 name VLID15_DMZ by port
tagged lag 1
!
vlan 20 name VLID20_CONSULTANT-VLAN by port
tagged lag 1
!
vlan 50 name VL50_VILATCALF by port
tagged lag 1
!
vlan 99 name VLID99_MGMT by port
tagged lag 1
!
vlan 3999 name DEFAULT-VLAN by port
!
errdisable recovery cause bpduguard
errdisable recovery cause loop-detect
errdisable recovery interval 30
!
mstp scope all
mstp instance 0 vlan 1 to 6
mstp instance 0 vlan 8
mstp instance 0 vlan 10 to 15
mstp instance 0 vlan 20
mstp instance 0 vlan 50
mstp instance 0 vlan 99
mstp instance 0 vlan 3999
mstp admin-pt2pt-mac lag 1
mstp admin-edge-port ethe 1/1/1 to 1/1/24
mstp start
!
!
!
ip route 0.0.0.0/0 192.168.199.1
!
!
clock summer-time
clock timezone gmt GMT+01
hostname KALVERSTAL
ip tftp blocksize 8192
!
!
ntp
server 91.182.44.189 burst
server 45.87.77.15
!
!
!
!
!
!
!
!
!
interface management 1
!
interface ethernet 1/1/1
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/2
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/3
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/4
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/5
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/6
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/7
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/8
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/9
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/10
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/11
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/12
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/13
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/14
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/15
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/16
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/17
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/18
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/19
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/20
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/21
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/22
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/23
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface ethernet 1/1/24
loop-detection
stp-bpdu-guard
trust dscp
broadcast limit 300
multicast limit 300
!
interface lag 1
broadcast limit 300
multicast limit 300
!
interface ve 99
ip address 192.168.199.4 255.255.255.0
no spanning-tree
!
!

!
!

 

!
!
!
!
username super password 1 $6$M78fhauw$U9v04M38MHQJICVI2B.CUB2ifrYKmqtO5AsgEjmVQkY5KDSu.OrP4eClPFo8kjfdfj6x6WMNARpiMQ6moP/Mz/
username admin password 1 $6$M78fhauw$U9v04M38MHQJICVI2B.CUB2ifrYKmqtO5AsgEjmVQkY5KDSu.OrP4eClPFo8kjfdfj6x6WMNARpiMQ6moP/Mz/
!
aaa authentication login default local
!
aaa authentication web-server default local
!
aaa authentication snmp-server default local
!
ip dhcp-client disable
!


!
web-management disable
!


!


!
snmp-server community 2 $UGlkRGktfSV0azU= ro
snmp-server contact support@vanroey.be
snmp-server location "SopracoNV - Geel"
snmp-server group Ncentral v3 priv notify all read all write all
snmp-server user Ncentral Ncentral v3 encrypted auth sha e474cbbc4bfc3b31f15fdf003f450d5ad1e10758 priv encrypted aes 65a0f499727497e199a992388f3bdc90
!
manager active-list 192.168.168.19
manager registrar
manager port-list 987
!
cli timeout 240

 

Chandini
RUCKUS Team Member

 Hi SopracoIT

Thanks for  sharing the details. Please give me sometime to check with regard to this.

Thanks 

 

Chandini
RUCKUS Team Member

 Hi SopracoIT

I ran through the details and also checked about this internally. I don't see a major difference between the configuration for 7150 and 8200 switch. 

Would you be able to upgrade the 8200 switch to 10.0.10c_cd3 version and test  ?

Link:

If you still see the problem , I request you to log a case with us to further isolate on the issue using the below link:

Thanks