Showing results for 
Search instead for 
Did you mean: 

Configuring SFP port on 7150-C08p

New Contributor III


I have a pair of 7150-C08p switches. 

We installed a 1GbE optical gbic in 1/2/1 on each switch and patched them together...

We are not getting any link.

I am trying to determine if this is a:

Switch config issue?

GBIC compatibility issue?

Cabling issue?

The switches see the gbic installed, but it is down:

ICX7150-C08P Switch#show media
Port 1/1/1:  Type  : 1G M-C (Gig-Copper)
Port 1/1/2:  Type  : 1G M-C (Gig-Copper)
Port 1/1/3:  Type  : 1G M-C (Gig-Copper)
Port 1/1/4:  Type  : 1G M-C (Gig-Copper)
Port 1/1/5:  Type  : 1G M-C (Gig-Copper)
Port 1/1/6:  Type  : 1G M-C (Gig-Copper)
Port 1/1/7:  Type  : 1G M-C (Gig-Copper)
Port 1/1/8:  Type  : 1G M-C (Gig-Copper)
Port 1/2/1:  Type  : 1G M-LX(SFP)
Port 1/2/2:  Type  : EMPTY

ICX7150-C08P Switch#show interfaces brief

Port       Link    State   Dupl Speed Trunk Tag Pvid Pri MAC             Name
1/1/1      Down    None    None None  None  No  1    0   c0c5.20b0.d0ad
1/1/2      Up      Forward Full 1G    None  No  1    0   c0c5.20b0.d0ae
1/1/3      Down    None    None None  None  No  1    0   c0c5.20b0.d0af
1/1/4      Down    None    None None  None  No  1    0   c0c5.20b0.d0b0
1/1/5      Up      Forward Full 1G    None  No  1    0   c0c5.20b0.d0b1
1/1/6      Up      Forward Full 100M  None  No  1    0   c0c5.20b0.d0b2
1/1/7      Up      Forward Full 100M  None  No  1    0   c0c5.20b0.d0b3
1/1/8      Up      Forward Full 100M  None  No  1    0   c0c5.20b0.d0b4
1/2/1      Down    None    None None  None  No  1    0   c0c5.20b0.d0b5
1/2/2      Down    None    None None  None  No  1    0   c0c5.20b0.d0b6

ICX7150-C08P Switch#show interface ethernet 1/2/1
GigabitEthernet1/2/1 is down, line protocol is down
  Port down for 125 day(s) 5 minute(s) 48 second(s)
  Hardware is GigabitEthernet, address is c0c5.20b0.d0b5 (bia c0c5.20b0.d0b5)
  Configured speed 1Gbit, actual unknown, configured duplex fdx, actual unknown
  Configured mdi mode AUTO, actual unknown
  Untagged member of L2 VLAN 1, port state is BLOCKING
  BPDU guard is Disabled, ROOT protect is Disabled, Designated protect is Disabled
  Link Error Dampening is Disabled
  STP configured to ON, priority is level0, mac-learning is enabled
  Flow Control is config enabled, oper enabled, negotiation disabled
  Mirror disabled, Monitor disabled
  Mac-notification is disabled
  VLAN-Mapping is disabled
  Not member of any active trunks
  Not member of any configured trunks
  No port name
  IPG MII 96 bits-time, IPG GMII 96 bits-time
  MTU 1500 bytes
  MMU Mode is Store-and-forward
  300 second input rate: 0 bits/sec, 0 packets/sec, 0.00% utilization
  300 second output rate: 0 bits/sec, 0 packets/sec, 0.00% utilization
  0 packets input, 0 bytes, 0 no buffer
  Received 0 broadcasts, 0 multicasts, 0 unicasts
  0 input errors, 0 CRC, 0 frame, 0 ignored
  0 runts, 0 giants
  0 packets output, 0 bytes, 0 underruns
  Transmitted 0 broadcasts, 0 multicasts, 0 unicasts
  0 output errors, 0 collisions
  Relay Agent Information option: Disabled
  Protected: No
  MAC Port Security: Disabled

 This port is not being monitored for queue drops
Egress queues:
Queue counters    Queued packets        Dropped Packets
         0                   0                   0
         1                   0                   0
         2                   0                   0
         3                   0                   0
         4                   0                   0
         5                   0                   0
         6                   0                   0
         7                   0                   0

Is there anything from a switch config standpoint that I can check? These switches have not had any explicit configs done to them... they are pretty much right out of the box...

I have ordered a couple different GBICs just in case the ones we have are incorrect.

Our fiber environment is single mode with regular LC connectors.




Hey There, 

No special considerations here. That port should be fixed 1Gb, so no need for speed settings or anything like that. I would assume this is a media (optic, fiber, etc.) issue, but tough to say without doing process of elimination. If needed, please feel free to open a case (see my signature) and we can try to help,

Ben Beck, RCNA, RCNI, Principal Technical Support Engineer

View solution in original post

RUCKUS Team Member

Hi James,

Please open up a support ticket and work with our TAC to find out why it is not working.

Link to open a case:

Hope this helps



View solution in original post

New Contributor III

lol - ok - so I convinced myself that I wasn't going to totally break the fiber cable trying to get the LC connectors out of the clip... I flipped the cables on one side, plugged in to the gbic and got a link light. So... seems that was the issue.

Appreciate everyone's help... and patience with me being such a freshie with fiber 🙂 lol

View solution in original post

Valued Contributor II

The first thing I would do -- put switches side by side, and connect by 2m patch. If no link, swap pairs on one end. If still not working, replace both SFP with known working.

Than I would check if it works with 2 different vendor switches (I mean test same cable + SFPs with different switches).

Only if this way I could determine that all components work with different swicthes, I would open support case.

But it is probably as simple as cable problem, try troubleshooting physical level in the beginning... FO cable fault laser tester helps a lot to be sure you have proper cable connections.

View solution in original post


New Contributor II

'show media validation' if you are running a current OS on the switch will verify the SFP is compliant with Brocade.

If this is a 10G capable port you would have to hard code the speed:

config t

int e 1/2/1

speed 1000-full

Only other issues would most likely be physical cabling, possible roll of fiber.

You show to have a LX sfp module inserted into 1/2/1. LX is for single mode(usually yellow). If the switches are in the same room for testing you would be better off with multi-mode fiber and SX modules. 

Yes - our fiber is single mode. I have one of the switches in our MDF and the other is in an IDF at the far end of the building.


Have you tried to reverse the fiber pair on one end?  I see this one new fiber installs and have to change one end so that send one one end hits receive on the other end.