Showing results for 
Search instead for 
Did you mean: 

C110 Upgrade Firmware Greyed Out

New Contributor

I think I previously posed this in the wrong category.  Sorry about that.  I didn't realize initially how this forum worked.

I have a c110 that has both firmware buttons (Online Upgrade & Local Upgrade) greayed out (see screenshot).  Something perhaps went wrong in an upgrade somewhere...  Is there a way to start at the beginning with a known good starter firmware and reset to factory defaults.  Perhaps with Putty/SSH  or upgrading off of a USB thumb drive?

Image_ images_messages_6176fe0f793b38530dd06e9d_89c04c5740d4275c33b090162190c25f_C110FirmwareGreyedOut-33a72e22-b30d-47fa-bb79-90436bb9c77d-279518979.png


I tried to login with WinSCP using FTP protocol on port 22.  using the GUI username and password.  

I get a message saying "access denied".  Is there a different username & password for FTP?

Hi David,

Ask was to upgrade AP using AP CLI over FTP.

Here are the commands.

Using TFTP:

fw set proto tftp
fw set host
fw set control
fw upgrade

Using FTP:

fw set control <FIRMWARE_FILE>
fw set proto ftp
fw set host  <FTP_SERVER_IP>
fw set user <FTP_USERNAME>
fw set password <FTP_PASSWORD>
fw up

Syamantak Omer

RUCKUS Networks, CommScope!

Follow me on LinkedIn

Im looking through various Ruckus support youtube videos.  It would appear that there is a firmware upgrade progression that sometimes must be followed.  I may have skipped a necessary firmware upgrade step.  How can I determine if a firmware needs a certain upgrade progression.  Ive dug around a little bit on the ruckus download site, but I don't see what I am looking for.

The CLI firmware upgrade also fails.  Any ideas of what I can try next?

ruckus(ap-mode)# fw up
fw: Updating rcks_wlan.bkup ...
v54_fw_update: download section=rcks_fw.main image=Image2 ctl_file=C110_200. (/writable/fw/main.cntl)
Error: net_get_buf- FW_CTL_ERROR
Error: net_get_buf- FW_CTL_ERROR
**fw(625) : CTL Get Error

RUCKUS Team Member

Hi David,

that message means you are not able to reach the ftp server somehow. Make sure that if there's a firewall all the ports are opened for this.