cancel
Showing results for 
Search instead for 
Did you mean: 

dhcp request problem in 5Ghz wifi roaming on samsung s10.

jungyu_park
New Contributor III

R610 / Unleashed 200.12.10.105.129

 

Hello.

Have any issue in the title been reported?
I sent data such as client logs and AP packet captures to Samsung for a month, but the answer I got back was, please contact the AP manufacturer.

The problem is that whenever my S10+ roams at 5Ghz, it gets a new dhcp.
It happens on both wpa2 and wpa3, no problem at 2.4Ghz.

I tested roaming on s10+, z flip3, tab s6 lite, tab s8, but there is only a problem with s10+ 5ghz.

I left a request again, including a google link with images of client trouble shooting, but I'm also posting here.

https://drive.google.com/drive/folders/1KwJQPJws09W5LmarJI21SF_uyV5L7pPh?usp=share_link

 

s10+-3.png

2 ACCEPTED SOLUTIONS

syamantakomer
Moderator
Moderator

Hi @jungyu_park,

This seems like an issue on client device side because I do see roaming happening correctly (you can see re-association frames in the connection trace).

Please note, AP doesn't interrupt or temper client IP acquisition (other than VLAN configuration on WLAN and if you enable force DHCP).

A packet capture and AP logs may help here but for that I would suggest opening a support case for better troubleshooting and quicker resolution.

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

View solution in original post

There was a firmware update for the s10+ this morning. (G975NKSU7HVJ5)

Samsung replied to my inquiry, "Please talk to the AP manufacturer", and "if you have any additional questions, you should ask again with a new log."

But strangely, after updating to the new firmware, the problem cannot be reproduced.

That's right. Now, even when roaming at 5Ghz, dhcp does not renew.

It feels like it's been resolved.

View solution in original post

10 REPLIES 10

Rao
Internal Employee

Hi @jungyu_park,

We do not have any known issue with S10+ not being able to receive DHCP IP on 5Ghz radio. From the client troubleshooting screenshot provided, I can see that the DHCP ACK from the server is being forwarded to the client through AP. Would you be able to verify if a valid IP is seen in the DHCP ACK info field on the same client troubleshooting page? Additionally in order to fully trace the DHCP packet, we need to collect a packet capture from the AP 5ghz radio which will give more info on the problem. You can follow the step mentioned in https://docs.commscope.com/bundle/unleashed-200.11-onlinehelp/page/GUID-FE747C7C-8F63-409B-A423-63F8... to gather the packet capture using which we can identify if the DHCP packets are forwarded to client or not.

Regards,

Rao

 

 

jungyu_park
New Contributor III

I have additionally uploaded the packet capture files I sent to Samsung to the Google Drive link.

syamantakomer
Moderator
Moderator

Hi @jungyu_park,

This seems like an issue on client device side because I do see roaming happening correctly (you can see re-association frames in the connection trace).

Please note, AP doesn't interrupt or temper client IP acquisition (other than VLAN configuration on WLAN and if you enable force DHCP).

A packet capture and AP logs may help here but for that I would suggest opening a support case for better troubleshooting and quicker resolution.

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

Hello.
Thank you for answer.
I also think it's a client's problem, but I don't know how much Samsung will care about the S10+, which is close to EOL.