cancel
Showing results for 
Search instead for 
Did you mean: 

Created vlan but no PVID is assigned to interface?

john_lieberman_
New Contributor II
I've created a vlan and assigned an interface to that vlan as well as ve and assigned it an ip. however when i show interface brief it shows the pvid as vlan 1. Shouldn't it automatically assign the vlan id of the untagged port assigned to it? 
9 REPLIES 9

BenBeck
Moderator
Moderator
Hey John, 

Can you provide the following output and note the port:

show run
show vlan 
show vlan brief

Did you apply that interface as tagged or untagged? Depending on the code level you are on, even if you tag a port to a vlan, it will still exist in the default vlan as untagged (think native vlan or our old method known as dual-mode). This allows untagged traffic to pass on the interface. 
Ben Beck, RCNA, Principal Technical Support Engineer
support.ruckuswireless.com/contact-us

thx for the reply. dont have access to the switch at the moment. here s a copy of the config tho. also its SW: Version 08.0.80dT213 - so no dual-mode. both tagged and untagged as needed.

show run

Current configuration:
!
ver 08.0.80dT213
!
stack unit 1
  module 1 icx7150-c12-poe-port-management-module
  module 2 icx7150-2-copper-port-2g-module
  module 3 icx7150-2-sfp-plus-port-20g-module
!
!
global-stp
!
!
!
vlan 1 name DEFAULT-VLAN by port
!
vlan 100 name data by port
 tagged ethe 1/1/1 ethe 1/1/3 to 1/1/12 
 router-interface ve 100
 spanning-tree 802-1w
!
vlan 101 name Voice by port
 tagged ethe 1/1/2 to 1/1/12 
--More--, next page: Space, next line: Return key, quit: Control-c
router-interface ve 101
 spanning-tree 802-1w
!
!
!
!
!
!
!
!
!
!
!
!
!
boot sys fl sec
hostname Evergreen-ICX7150-C12
ip route 0.0.0.0/0 10.12.100.254
!
!
!
!
!
--More--, next page: Space, next line: Return key, quit: Control-c
!
!
!
!
!
!
!
!
interface ethernet 1/1/3
 loop-detection
 spanning-tree 802-1w admin-edge-port
 trust dscp 
!
interface ethernet 1/1/4
 loop-detection
 spanning-tree 802-1w admin-edge-port
 trust dscp 
!
interface ethernet 1/1/5
 loop-detection
 spanning-tree 802-1w admin-edge-port
 trust dscp 
!
--More--, next page: Space, next line: Return key, quit: Control-c
interface ethernet 1/1/6
 loop-detection
 spanning-tree 802-1w admin-edge-port
 trust dscp 
!
interface ethernet 1/1/7
 loop-detection
 spanning-tree 802-1w admin-edge-port
 trust dscp 
!
interface ethernet 1/1/8
 loop-detection
 spanning-tree 802-1w admin-edge-port
 trust dscp 
!
interface ethernet 1/1/9
 loop-detection
 spanning-tree 802-1w admin-edge-port
 trust dscp 
!
interface ethernet 1/1/10
 loop-detection
 spanning-tree 802-1w admin-edge-port
--More--, next page: Space, next line: Return key, quit: Control-c
 trust dscp 
!
interface ethernet 1/1/11
 loop-detection
 spanning-tree 802-1w admin-edge-port
 trust dscp 
!
interface ethernet 1/1/12
 loop-detection
 spanning-tree 802-1w admin-edge-port
 trust dscp 
!
interface ethernet 1/3/1
 speed-duplex 1000-full
!
interface ethernet 1/3/2
 speed-duplex 1000-full
!
interface ve 100
 ip address 10.12.100.1 255.255.255.0
!
interface ve 101
 ip address 10.12.101.1 255.255.255.0
--More--, next page: Space, next line: Return key, quit: Control-c
!
!
!
!
!
lldp med network-policy application voice tagged vlan 101 priority 4 dscp 46 ports ethe 1/1/1 to 1/1/12 
lldp med network-policy application voice-signaling tagged vlan 101 priority 5 dscp 34 ports ethe 1/1/1 to 1/1/12 
lldp run
!
!
!
!
!
end

 

Got it. So are you seeing pvid 1, correct? This would be expected as that column is showing you the untagged vlan more or less. All of your tagged ports there still exist in vlan 1 untagged since it is the default vlan. The 'show vlan' would confirm that I believe. 
Ben Beck, RCNA, Principal Technical Support Engineer
support.ruckuswireless.com/contact-us

the problem is i can't ping anything on either vlan. can't ping the router 1/1/1 can't ping the voice server in port 1/1/2. the arp table shows nothing. I figured the PVID not showing the vlan member meant something was wrong with config or switch.