Showing results for 
Search instead for 
Did you mean: 

Bootstrapping error at "Certificate and Root Key created"

New Contributor

Hi Ruckus Forums,

I'm trying to simulate the HTTP API v5.2 from a Ruckus Virtual SmartZone device version in QEMU with KVM accelerator, and I can not set the device up because it keeps forever in the Certificate and Root Key created part with an error traceback.

It's important to notice that I tried first the version 3.0.3, and it worked just fine.

Ruckus error

I tried the set-up from both CLI and Web, none succeeded. I also tried different combinations of options in the set-up, like Manual and DHCP network configuration, different and same password for admin and CLI, again none worked.

However, I can give a hint about what's going on. The following images show that during the Certificate and Root Key created part, the web server suddenly goes down:

Web network 1Web network error 2

Then, when trying to list the interfaces in the CLI, Tomcat shows up:

Tomcat error

Another information: I also tried Ruckus Virtual SmartZone, and it fails exactly the same.

Tools and versioning:

  • Ubuntu - 18.04.6
  • qemu-system-x86_64 - v2.11.1
  • Ruckus Virtual SmartZone - v5. and v5.

I would appreciate help with this issue.




Community Manager
Community Manager

I don't think QEMU is a supported platform for vSZ product. This is why it might be failing.

Syamantak Omer | Sr.Staff TSE | CWNA | CCNA | RASZA | RICXI

Thanks for your reply.

I do think QEMU is supported, by the following facts:

1. they have the image for QEMU

2. The version 3.0.3 worked just fine, in the same machine just hours earlier.

3. I suppose if QEMU was not supported, the machine would not even start, or at least throw a considered amount of errors.

However, you could be right.

In the case QEMU is really supported, do you know if upgrading Ruckus Virtual SmartZone is straight forward? If yes, I could get a working version and upgrade all the way to the version I want.

If QEMU is not really supported, do you know an officially supported hypervisor I could give it a shot?


Community Manager
Community Manager

I was looking into the release notes but there is no mention of QEMU being supported.

Also recent release 6.0 and 6.1 also has not mention of it under supported hypervisors.

I am still checking if this is officially support or not.

Syamantak Omer | Sr.Staff TSE | CWNA | CCNA | RASZA | RICXI