Showing results for 
Search instead for 
Did you mean: 

Ruckus will not turn on

New Contributor

Lennar installed ruckus is receiving no power. No lights in the device are on. I have tried unplugging and replugging. I have also tried to reset. Any help is appreciated.



Hi @Jalexan7 

Can you confirm what of the Ruckus component you are referring too, you may have a ICX 7150 Switch that must be in a cabinet and 1 or two Access Points that must be on your ceiling, Please provide a picture.

Left one will be the Switch and the one on the ceiling is the Access Point, important the ICX 7150 Switch is the one that provides power to the Access Points on the ceiling.


Best regards,

Yarenis Hernández

Technical Support Engineer | L2 TAC Wired


New Contributor

I am having the same issue, no power to Access Ports.....I have the ICX 7150. This occured two years ago and Ruckus tech did the troubleshooting online. Can you provide guidance? Next Steps?

Hi @Trowman80 

if you have the next Symptoms, Please follow up the software recovery guide that I will add, if not, please describe:

*The Switch will not provide power to any PoE devices (Doorbell, cameras, even the Access Points).

*Will not have connectivity to the devices connected to the Switch.

*The ISP router will work fine.

*Console access will be the only access available.

*System light will be yellow/orange/Amber.


Note: Please read the guides carefully before start the troubleshooting.

How to perform a Software recovery on an ICX7150 switch

Ruckus ICX Recovery Load boot code from boot monitor


Best regards,

Yarenis Hernández

Technical Support Engineer | L2 TAC Wired