Showing results for 
Search instead for 
Did you mean: 

Ruckus switch is not powering on (ICX7150-C12P-2X1G)

New Contributor

When I looked at the Ruckus switch (ICX7150-C12P-2X1G), there is no power light. I tried remove plug and plug it back on. Same power cable worked with my monitor. Sounds like the ruckus switch gone bad. Do I need RMA? if so, what's the process



Hi @ammuraj 

1-Please provide us a complete picture/photo showing the front of the switch and that it is properly connected to a power source.

upload photo.png

Best Regards 

Fernando Vasquez 

It says " You do not have permission to upload images" when i tried to drag and drop files.

Ruckus switch - Front.jpeg

Ruckus switch - Back.jpeg

 Able to do after sign in

Hi @ammuraj


Thank you for the details provided, based on the troubleshooting you have done since the ICX7150 is no longer powering up, this unit must be RMA (return merchandise authorization), which means to replace it.

Contact us via chat, comment that you already have a post that we have approved the RMA for you, copy the link from this post and paste it into the chat to initiate the unit replacement.


Chat Link



Note: Please feel free to mark the post as ACCEPTED SOLUTIONS


Best regards,

Yarenis Hernández.

Technical Support Engineer | L2 TAC Wired | Lennar Home Community