Showing results for 
Search instead for 
Did you mean: 

Ruckus ICX-7150-C12P

New Contributor II

Internet is working fine. switch is not working and also all access points including Ring door bell is not working. Can you help me fixing issue. this issue happening after power trip. its urgent and I'm not able to use wifi due to this issue.


Hi Imran,

Do you have any document or video how to connect ICX-Switch and which software is required software recovery ?


View solution in original post


Hi @mschowdary 

Thank you for the response. 

Could you please let me know if you tried to reset your Switch as explained in the previous guide? If the reset doesn’t work, we have to go for Software recovery of the Switch.

All the steps have been explained in the software recovery guide shared in the previous post. Please refer and follow the same guide to perform the software recovery process on your ICX-7150-C12P Switch. Also, there is a video for the reference. 

Please let me know if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

Thanks Imran. Its working fine after resetting multiple times.

Hi @mschowdary 

Greetings of the day!!!

Thank you for the response and update.

Great!!! Good to know that the issue is now resolved. 

We appreciate your time and patience on this case.

NOTE: Please feel free to mark the troubleshooting post as ACCEPTED SOLUTIONS.

Thank you again for contacting RUCKUS Lennar Home Community and feel free to contact us for future queries.

Have a great day ahead!!!


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

Hi @bbatjargal11 


Thank you for contacting RUCKUS Lennar Home Community.

Hope you are doing well

As this case is raised by @mschowdary which is now resolved.

To avoid confusion with posts, you can create your own post with the problem you're facing and a detailed description of the network issue and what you've done so that we can guide you properly.

Thank you again for understanding.

Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

HI Imran, 

I have the exact same problem. Can you please help? I tried to reset the switch by telnet through Putty - but there is no serial (COM) number available for the console. Tried various ways, not working.