Showing results for 
Search instead for 
Did you mean: 

Ruckus ICX 7150-C12P upon powering up, all lights flash amber and then no power or lights are on

New Contributor


I saw many others with this same issue in a lennar home, the switch all of a sudden stopped working in the middle of the day, no power surge or anything.


The switch when plugged into power, all the lights on the front flash amber and then nothing happens. 

I have tried multiple outlets, I’ve held the reset button upon powering up, nothing has worked.

is there a resolution? 


RUCKUS Team Member

Hi DamianZ ,

Thank you for posting you query !!!

I understand that when ICX-7150-12cp plugged into power ,  you have noticed that all lights flash amber and then no power or light are on .

And as a troubleshooting step you have already tried hard reset and also tried on multiple outlets , Could you confirm us if have  you tried to use another power cable, if not just try to change the power cable if that doesn't resolve the issue then next step will be RMA. 

In case you are able to take cli access of the switch then you can perform software recovery process as mentioned below :

Please log a ticket with the below link so that we will help you to process RMA

Please confirm us if you are from Lennar Homes .

I hope this information helps you

Please feel free to leave us a message if any concerns


Hi @DamianZ 


Thank you for contacting RUCKUS Lennar Home Community.

Hope you are doing well!!!

Thank you for the information you shared.

As per the case description, I understand that your ICX-7150-C12P Switch is not powering up.

Could you please let me know if you tried to factory reset the RUCKUS ICX-7150-C12P Switch? If not below is the process. Please check and let me know if that works.

Please try to reset the Switch as described below in the VIDEO:

1. Please try to disconnect from the Power outlet the ICX-7150 and reconnect.

2. Please try to press the reset button using a paper click or a small stick 

  • Remove power from the switch.
  • Press and hold the Reset button while applying power to the switch.
  • After all the system LEDs flash amber, release the Reset button.

Video link:

IF THE RESET IS NOT WORKING, PLEASE TRY TO RESET YOUR SWITCH MULTIPLE TIMES (Like 10-15 times) AS DESCRIBED ABOVE. As we have seen it working sometimes after trying multiple times in many cases. If the reset with a paperclip works, the SYST and PWR lights should turn GREEN.

Please check and let me know if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

I have a ICX 7150-C12P that stopped working in the middle of the day and will not power on. I have tried to reset it multiple times but the lights dont come on at all. I have tried to connect it directly to my Mac where I was able to download and install the serial drivers but the device will not respond to terminal commands. 

I think I need to RMA this device. I tried to start that with the chat "fetch" service but not sure that was done properly. Any additional service/support would be greatly appreciated. 


Thank you , 

Andrew Filson

Hi @DamianZ 


Greetings of the day,


As this case was raised by @AndrewFilson 


Please open a new case explaining all the detailed description of the issue to avoid confusion.


Please let us know if you have any queries in this regard.



Best regards,


Lennar Home Community