Showing results for 
Search instead for 
Did you mean: 

Ruckus 7150 not powering

New Contributor


We have Lennar home with Ruckus network. I need assistance, my Ruckus 7150 switch it is dead and all Status lights and POE plugs are not powering APS. I have tried everything In messages posts including resetting it 15-20 times, unplugging it and replugging to different power outlets, connecting laptop to switch, but nothing works.  I am not familiar with rebooting the switch and can’t get it to appear in laptop with C usb connection to try. 

Can someone help on how to get a replacement and/or recommend a different brand switch with POE compatibility with Ruckus APs?

I appreciate your assistance,



Hi @Tpad 

Thank you for the response and the detailed information you shared.

Apologies for the inconvenience. Please do not worry, I will help you in resolving this issue Today.

Could you please, let me know the current light status of the RUCKUS ICX-7150-C12P Switch as there are different light statuses in the pictures you shared (Please refer below.

Also, as I see from the picture you shared, seems like the ethernet cable which is coming from the Router or Modem/Router combo is plugged into the wrong port on the Switch panel. It must be plugged into any 1 in-12 ports as shown in the below screenshot. Please unplug the ethernet cable and plug it into the correct port.

Please check, help us with the above-requested information, and let me know if you have any queries in this regard.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

Hello Imran,

hope you are well.

in the picture where it shows yellow  and green lights  switch is resetting. In the second picture two lights are green it has finished resetting and these are the only lights flashing on switch.

The grey Ethernet cable is coming from Xfinity modem and plugged input Ruckus switch (I believe C-2). Once switch is done resetting the light on grey cable lights up. This is the original hook up we were instructed to do when we moved in and Ruckus system (switch and Aps) were working fine. Is Xfinity cable modem supposed to be plugged into a different port?

The blue cables are connected to APs and they do not have any lights on similar to Status lights. 

Maybe switch is just not working and needs hands on repair by experts such as you. I work near Ruckus business in Sunnyvale and can easily drop by and pay for repairs. Or maybe you can recommend a place such Best Buy or somewhere to fix switch. Or different brand switch that can work with Ruckus APs since they are wired in our house, it can be our “secret “ to avoid any consequences from your bosses. This going back and forth on chats is kind of silly and inconvenient.  
What happened to good old fashion customer service,  

I appreciate your assistance, thanks.


Hi @Tpad 

Thank you for the response and the detailed information you shared.

Apologies, effective November’2022, ‘Ruckus Support for Lennar Homes customers will no longer be handled by phone or email or remote session. We will be exclusively supporting customers via this community forum support model only.

As your RUCKUS Switch has 2 Green lights, it means it’s in a normal state. However, we may have to check ports and some other information to resolve this issue. Please follow the below steps to check the same and help us with the queries.

Please follow the below steps and help us with the queries,

1. To check this issue, we must identify the ‘current’ IP address assigned by your local router to the switch ICX-7150-C12P

I will leave you a guide on how to perform an IP scanner on your local network to identify the switch IP address very easily. 

How to find my Ruckus “Devices IP address” using free applications:

2. Once we identify the IP address of the switch proceed to access remotely to the device “Command Line” 

How to remotely access to 'ICX 7150-C12P' or 'access points' "Network devices":

If you can access the Command line should look like this:

ICX7150-C12 Router> OR

ICX7150-C12 Switch>

Please enter the below commands once you log in to CLI and share the output.

Note: Hit Enter to accept each command 


show version

show flash

show inline power 
show interface brief

Please share the output of the above commands or share the screenshots if stuck at any step or error (if any) and let me know if you have any queries in this regard.

Thank you again. We appreciate your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

Hi @Tpad 

And please unplug and plug the ethernet cable coming from Xfinity Router, as described in my previous post.

Thank you again.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

Hello Imran,

Hope all is well.

I am frustrated and cannot get this switch to work. I have reset it more that 50 times and tried to connect it to my computer through C usb drive and it does not work and/or connect.  You can look at photos I attached. 

Rather that continue this lovely sing and dance on this ridicules ineffective group chat, can you check if switch is under warranty and if I can return and get another one, refurbished or new.  Or suggest a computer shop in Bay Area such as Sunnyvale or San Jose that can assist with "magic" in person services and take a hands on approach.  Nothing about you, I am sure you are great at your job but this going back and forth is not resolving me issues.  It sounds like many neighbors are having same issues and Ruckus has been unable to resolve their issues. 

Please, to avoid wasting our time, just check to see if I can get a new, refurbished, and/or replacement that is all I need.  Then, we can get over this painfully useless chit chat and move one.  That is how you can save the day and really assist me. 

Come on be a real hero today!!!!