Showing results for 
Search instead for 
Did you mean: 

Power Failure Causes Switch to reboot into Router Mode

New Contributor II

I have a ICX 7150 C12 Ruckus Switch provided to me by my home builder Lennar with two R510 APs. We had a power outage in my area and it caused the switch to boot into router mode when it should be in switch mode. This is causing my system to do some weird things and we didn't have this problem before the outage.

How do I go about fixing this? The home builder Lennar initially set everything up for us so I am unfamiliar with the majority of the setup process. I will need a step by step instruction as I understand the basics but I am also very new to this. It was asking me for a password in the Unleashed app but I don't have one for the switch only the router, will I need to factory reset the system? If so how will I go about factory reseting?

I will then need help figuring out how to connect to the switch so I can make the changes needed. Is it as simple as typing in the address on the switch into the browser URL like I would a router? Or do I need to manually plug into the switch via ethernet or some other way? After I figure that out I will need to know how I go about changing it. Is there a command prompt and if so what commands do I type to get it to boot into the proper mode? Also, is there a way to keep it from booting to router mode every time there is a power outage?


New Contributor II

Hey Brock, I encounter this issue quite often. I did a write up 4 months ago that may help if you are comfortable with CLI:

My problem is I've seen some other posts mention they can flash the switch image to both partitions, but I haven't succesfully done this yet. This causes a mountain of headaches whenever something networking pops up I have to check if the switch rebooted.

View solution in original post



Yes, very good point.

In my case, primary (SPS8090d) would not boot up for some reason.   A log entry "System failed to boot from primary !!" is logged, then it retries and boots secondary every time.   I ran a verify md5, and it matched the proper hash, so the image was not corrupt.  This made me afraid to set up SPS on secondary since it was unclear the reason why it was unable to run it from primary.  

When I upgraded to SPS8095d it did boot, so I copied that to secondary once I confirmed things were operating normally. 

New Contributor


I have on multiple times, with your instructions on other posts. I was able to finally get it to work using -

’boot system flash primary yes’

I just plugged in the replacement, I received from Ruckus and worked with no issues. 

My Ubiquiti system is still on its way.

@salvador_anguiano glad to know that you were able to fix it!

Syamantak Omer

RUCKUS Networks, CommScope!

Follow me on LinkedIn

New Contributor

Hi Brock, did you figure out how to do this? I need to do the same thing but don’t understand anyone’s instructions on this format. It’s all too complicated. Thanks!