Showing results for 
Search instead for 
Did you mean: 

No power to unit

New Contributor

Ruckus unit stop working, no power, won't reset, no lights displaying. The unit is dead. Yes....I tried a different outlet, restarting it and it is still not working. 



Hi @LSchmidt 


Thank you for contacting RUCKUS Lennar Home Community.

I hope you are doing well!!!

Thank you for the information you shared.

As per the case description, I understand that your RUCKUS ICX-7150-C12P Switch is not powering up.

Could you please plug your ICX-7150-C12P Switch into a working power outlet and send us PICTURES and VIDEO of it showing the light status, and cord connected to the Switch and power outlet? Please refer to the below pictures as an example.

Please use the below link to upload a VIDEO:

Please let me know if you have any queries in this regard.

Thank you again for your patience and understanding. 


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

Photos and video were uploaded to the link provided 

I have also tried to access my IP address but since I am not getting any internet connect the putty software is unable to access anything

Hi @LSchmidt 

We greatly appreciate all the information you've provided. 

From the video and images, I can see that the Ruckus white box on the closet has lights and one of them is yellow/amber (SYST light)

It seems that the switch (Ruckus white box)  went to a state that we called "boot-mode" and is not able to boot up properly.


*The Switch will not provide power to any PoE devices (Doorbell, cameras, even the Access Points (R510, device on the ceiling)).

*Will not have connectivity to the devices connected to the Switch.

*The ISP router will work fine.

*Console access will be the only access available.

*System light will be yellow/orange/Amber.

1-Please try to disconnect from the Power outlet the ICX-7150 and reconnected.

2-Please try to press the reset button using a paper click or a small stick
    1. Remove power from the switch.

    2. Press and hold the Reset button while applying power to the switch.

    3. After all the system LEDs flash amber, release the Reset button. 
Video link:

If that does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted so in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

3-We need to access (physical) using one of the cables to the ICX-7150C12P mentioned on the below guide:

How to console in the ICX-7150-12cp


4- Upon reaching that point, pressing the Enter key on the keyboard will reveal the following:


5- Please follow the guide "How to perform a Software recovery on an ICX7150 switch" on the link below to fix the issue

Here is the guide: 

Video Link:

Kind regards,

Sofia Gätjens