Showing results for 
Search instead for 
Did you mean: 

Lennar Home: Ruckus ICX 7150 not powering up

New Contributor


I am using the Ruckus ICX 7150 with access points that came with my new Lennar home. The switch is not powering up now and my AP’s and Ring door bell do not work as the POE ports are not working. The community search provides a resolution to this problem which is to replace faulty equipment under lifetime warranty. Can a technical support engineer please approve the RMA for Case#01603412.

Thank you.

Gautam Dharmapuri


RUCKUS Team Member

Hi Madhugaut

Thank you for reaching us 

Apologies, effective November’2022, ‘Ruckus Support for Lennar Homes customers will no longer be handled by phone or email or remotes session. We will be exclusively supporting customers via this community forum support model only. You can always feel free to reach us on portal with any concerns you have. 

As per the details provided I understand that your RUCKUS setup is not working.

Could you please let us know the below details to understand the issue better ?

1. Was this working before or is it a new installation? If it worked before, was there any power outage before you started facing this issue?

2. On your switch while it's plugged into the outlet, do you see any lights on? (Amber or green) Please let us know which lights are on. (Please refer to the below picture and share a picture of the same, showing the light status and the FULL Switch panel cable connections to the Switch ports)



3. Is your Internet Connection from the Internet Service Provider (ISP) stable and working? (You could check this by connecting to your local router Wi-Fi or from an ethernet cable from the Router to a laptop/PC).

4. May I know how many Access Points are connected to the Switch? Could you please let me know the light status on the Access Points? Any of these lights are on (Please refer to the below picture and share a picture of the same)


Please help us with pictures of your ICX-7150-C12P Switch showing the status of the lights and cable connections to the Switch ports. Also, light the status of Access Points.

Before uploading the photos please log in to the RUCKUS account and you can upload the image.

Please feel free to reach us if any concerns.

Hi Chandini,

1. The switch and 2 WAPs were installed in my new home and have been working for 5 years now.

2.The problem with the ruckus switch is that it doesn’t power up anymore. When I reconnect to power four lights blink once in amber color and no power after that. We have 2 WAPs which do not power as there is no power from the switch.


3. I have a stable internet connection which is working with the connected wifi router.

4. I have 2 WAPs and nothing works.




Hi @madhugaut 


Thank you for contacting RUCKUS Lennar Home Community.

I hope you are doing well!!!

Thank you for the information you shared.

As per the case description, I understand that your RUCKUS ICX-7150-C12P Switch is not powering up.
Have you tried using a different power cord, in case the current power cord is damaged?

If yes, Could you please plug your ICX-7150-C12P Switch into a working power outlet and send us PICTURES and VIDEO of it showing the light status, and cord connected to the Switch and working power outlet? Please refer to the below pictures as an example.

Please use the below link to upload a VIDEO:

Please let me know if you have any queries in this regard.

Thank you again for your patience and understanding. 


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.