Showing results for 
Search instead for 
Did you mean: 

ICX7150-C12P System Light Amber, Power Light Green - Not Booting

New Contributor

Hello all!

Hoping you can help! We have a Lennar house built in 2020. Our ONT is connected to our Router which connects to the Ruckus Switch (Model in title). The system light is solid amber and the power light is solid green. I have no link lights to the switch on either the router or the Ruckus switch.

I have power cycled the switch several times as well as attempted to reset the switch. Telnet into the HostName or IP address of the switch when connected via USB C or CAT6 cable fails. Putty also cannot find the device. 

I found a similar post ( and their solution is to RMA. 

According to other posts, it seems as though the boot images may be corrupted and you may be able to telnet into it to fix it? However, we are unable to telnet into the switch. 

Any help is appreciated!! Thanks!



Hi @massetclan21 

On that case the RMA was approved since the USB console access did not work correctly.

But basically, due the power outage/ power spike the switch went to a state that we called (boot-mode) that is not able to boot up properly. 

That does not mean is broken or need to be replace 'in some cases'

1-Please try to disconnect from the Power outlet the ICX-7150 and reconnected.

2-Please try to press the reset button using a paper click or a small stick 

  1. Remove power from the switch.
  2. Press and hold the Reset button while applying power to the switch.
  3. After all the system LEDs flash amber, release the Reset button.

Video link:

If that does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted so in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

3-We need to access (physical) using one of the cables to the ICX-7150C12P mentioned on the below guide: 

How to console in the ICX-7150-12cp

Once we are there, we can try to boot up the unit using the following commands: 

Boot_primary or Boot_secondary 

If that step does not work Software recovery needs to be applied

Here is the guide:

 Video Link:

Best Regards 

Fernando Vasquez 


I have tried the below steps. Resetting and/or power cycling the device showed no effect. Issue persists

I was able to download and install the requested drivers. I was finally able to connect to the device using Putty (I couldn't find the correct COM port). Upon attempting any commands in Putty (e.g. boot_primary or boot_secondary), the screen displayed jibberish (see attached). I waited for it to finish but now it is jjust showing a blinking cursor in Putty and it is not allowing me to type any commands.


Hi @massetclan21 

Please try to disconnect and reconnect the unit from the power source and let me know the results 

Best Regards 

Fernando Vasquez 

Hello @vasquez_fer,

That is producing the same results. It is still not booting at all.