Showing results for 
Search instead for 
Did you mean: 

ICX disconnected from Unleashed; connectivity issues between AP and ICX

New Contributor II

Like everyone else here I have a Lennar-provided ICX 7150 and two APs. Something happened over the weekend and the ICX started showing up as Disconnected in the Unleashed GUI. Symptomatically things were 'connected', but traffic through the ICX to our ISP's stupid combo modem/router was having lots of issues.

I searched around on these forums (before finding the Lennar-specific section) and found some people with similar problems getting an ICX to connect to Unleashed. I tried factory resetting the ICX and re-adding it, but that didn't work. The ICX shows up in Unleashed as Pending, then prompts to enter the IP to join it (Auto Approve is enabled but seems like the ICX is in 'Router' mode per the docs?).

No matter what I have tried, after approving the ICX, it tries connecting and then shows up as Disconnected with a message that the ICX could not be pinged. 

I also updated the ICX to 08.0.90f via TFTP, but the result was the same.

I verified that LLDP is fine between the ICX and APs, but ICMP is not. I indeed can't ping the ICX from the AP, but I can ping it when I'm on the wired network from the ISP router. Interestingly when I'm connected to the router, I can't ping the AP directly. I can ping the AP if I'm on the wifi network being broadcast by Unleashed, but then I can't ping the ICX.

I know that was pretty hand-wavy but I can clarify if needed. 


Community Admin
Community Admin

Hi Jacob,

In a recent case, it was turned out the Ruckus switch booted into router mode. Customer had a brief power outage.

We booted it into switch mode and everything got stable! We also replaced the router image file with the switch image file so it won't go into the router mode in the future.

Check if if you hitting the same issue.

Syamantak Omer

RUCKUS Networks, CommScope!

Follow me on LinkedIn

View solution in original post


New Contributor II

On mine, the only obvious behavior difference was that the Unleashed app showed that it could not see the ICX switch.  It was that way for quite some time (probably weeks).   Only when I started to look into that did I notice I could only access the ICX's SSH or Web interfaces through my router's port (sshing to router then ssh to ICX).   I have several switches hanging off of it, and devices on those were communicating with the wifi devices and each other fine.     Maybe there's some luck involved as to which port things are hooked up to?

Someone else here shared that they had connection drops on wireless because of router mode.   I didn't experience that, either.  All of my wired and wireless devices still communicated fine with each other while the ICX was in "router" mode.

Definitely disappointing to see "enterprise" gear behaving this poorly.  I wouldn't have expected a managed switch to be a source of headaches at all.

New Contributor II

This same problem happened to my next door neighbor.  They switched from cable to fiber.   They must have powered down the ICX at some point during the install, and then their ICX got stuck in router mode.  In their case the APs would only communicate with the ISP gateway for a short period then fell off.  I applied the same fix (upgrading to 8095d, then copied switch mode to secondary after confirming successful boot of primary) and hopefully it fixes it for good for them.   

It's concerning to see this happen to two adjacent homes within the first few months of ownership. 

@rob_raper I’m guessing we all ended up with switches from the factory running a borked firmware. I’m also going to go out on a limb and say Lennar gets them preconfigured from the factory since they’re buying them in large enough quantities and whoever approved this version didn’t test it thoroughly.