Showing results for 
Search instead for 
Did you mean: 

ICX 7150 - Replacement

New Contributor

Effective November’2022, ‘Ruckus Support for Lennar Homes customers will no longer be handled by phone or email. We will be exclusively supporting customers via a community forum support model and hence no phone calls or emails will be accepted. You can find the Ruckus Support for Lennar Homes at ‘’ and select ‘Ruckus Lennar Support’ or by searching for it in your search engine of choice. You will need to create an account on the forum to receive support.

I have tried everything here and am unable to get this switch to reboot. I also cannot download files to my computer and access the switch remotely. 



Hi @Rickl 

Basically, due the power outage the switch went to a state that we called (boot-mode) that for that reason the ICX-7150-C12p is not able to boot up properly. 

That does not mean is broken or need to be replace 'in some cases'

1-Please try to disconnect from the Power outlet the ICX-7150 and reconnected.

2-Please try to press the reset button using a paper click or a small stick 

  1. Remove power from the switch.
  2. Press and hold the Reset button while applying power to the switch.
  3. After all the system LEDs flash amber, release the Reset button.

Video link :

If that does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted so in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

3-We need to access (physical) using one of the cable to the ICX-7150C12P mentioned on the below guide: 

How to console in the ICX-7150-12cp

Once we are there, we can try to boot up the unit using the following commands: 

Boot_primary or Boot_secondary 

If that step does not work Software recovery needs to be applied

Here is the guide:


Best Regards 

Fernando Vasquez 

Thanks I’ll give it a try. 

So I tried disconnecting the power and also the reset steps. The power is green but the System light is still amber. I’ll need to come back to this at a later date as I don’t presently have the time to get into the software recovery steps. Thanks for your help. Rickl