Showing results for 
Search instead for 
Did you mean: 

ICX 7150-C12P very slow

New Contributor

June 29th we had a power outage in the area and when it rebooted the speeds were extremely slow (ex. cannot open websites, house apps not working, cannot stream videos, etc).  I have checked these message boards and tried several things and it is still not working:

- restarted the switch / APs

- updated the firmware

- tried to re-add the switch on the portal (right now it shows disconnected and Unleashed system only supports ICX firmware version 08.0.90 or later.)

- tried the steps to view/update the route code using Putty ..... and so many other recommendations but nothing works!

Can someone contact me directly to help walk me through this?  I'm a regular person working from home and need my network up ASAP.


Hello @6423prl 


Thank you for your response and update.

To ensure compatibility with newer versions, please connect the Ethernet cables to any of the 12 available ports.

I recommend performing a factory reset on your RUCKUS Access Point and setting up a new Wi-Fi Network/SSID.

For detailed instructions on the factory reset process, please consult the RUCKUS Lennar Knowledge Base self-help guide available here:

If you have any questions or need further assistance, please feel free to reach out.

Thank you for your patience and cooperation.


Best regards,

Imran Sanadi  
RUCKUS Lennar Home Community

View solution in original post



Hi @6423prl 


Thank you for reaching out to RUCKUS Lennar Home Community for support.

I acknowledge the challenges you are facing with your RUCKUS setup and intermittent internet connectivity following a power outage. 

Based on the information provided, it appears to be a Routing Code issue.

To assist you in resolving this matter, please refer to our comprehensive self-help article in the RUCKUS Lennar Knowledge Base. This article provides detailed steps to troubleshoot and resolve the issue with your RUCKUS ICX 7150-C12P Switch:

Should you encounter any difficulties or have further questions while following these steps, please do not hesitate to reach out. 

Your patience and cooperation are greatly appreciated as we work towards resolving this issue promptly.


Best regards,

Imran Sanadi  
RUCKUS Lennar Home Community

New Contributor

I ran the putty prompts as suggested and the version showed that is was on the right SPS code:  "UNIT 1: compiled on Nov 20 2018 at 00:09:55 labeled as SPS08080d
(25968884 bytes) from Primary SPS08080d.bin"

and the flash showed Primary as SPS and secondary as SPR.

I ran the copy flash and reboot prompts anyway.  While it was rebooting, I got an error message: "Network error: Software caused connection abort"  but for about 30 minutes it seemed like it was fixed because the download speed was extremely fast (500mbps)!  Then it reverted back to being less than 1mpbs.

I checked the version again and it's still the same but the flash now shows both primary and secondary are SPS and still extremely slow.  Please advise:

NAND Type: Micron NAND 2GiB (x 1)
Compressed Pri Code size = 25968884, Version:08.0.80dT211 (SPS08080d.bin)
Compressed Sec Code size = 25968884, Version:08.0.80dT211 (SPS08080d.bin)
Compressed Boot-Monitor Image size = 786944, Version:10.1.14T225
Code Flash Free Space = 1190277120


Hi @6423prl 


I trust this message finds you well. 

We appreciate the information you've provided. 

Upon reviewing your case, it appears that your Switch is currently running on an older non-UFI version (08080d).

To ensure optimal performance tailored for Lennar Homes users, we recommend upgrading your Switch to the latest recommended version (08095g).

For detailed guidance on the upgrade process, please consult our RUCKUS Lennar Knowledge Base self-help article available at:

Should you encounter any challenges during the upgrade process, please do not hesitate to reach out to us. We are here to assist you every step of the way.

Thank you once again for your cooperation and patience.


Best regards,

Imran Sanadi  
RUCKUS Lennar Home Community

New Contributor

I upgraded the primary and seconday flash but the unit is still extremely slow on the download.  I am getting less than 1 mbps download, and 32mbps upload (my plan is for 500mbps / 35mbps).  Below is a screenshot of the version and flash now, please advise!

Stack unit 1:
NAND Type: Micron NAND 2GiB (x 1)
Compressed Pri Code size = 31457280, Version:08.0.95gT211 (SPS08095g.bin)
Compressed Sec Code size = 31457280, Version:08.0.95gT211 (SPS08095g.bin)
Compressed Pri Boot Code size = 786944, Version:10.1.14T225 (mnz10114)
Compressed Sec Boot Code size = 786944, Version:10.1.24T225 (mnz10124)
Code Flash Free Space = 1038815232
SSH@ICX7150-C12-Switch#show version
Copyright (c) Ruckus Networks, Inc. All rights reserved.
UNIT 1: compiled on May 6 2022 at 23:24:50 labeled as SPS08095g
(31457280 bytes) from Secondary SPS08095g.bin (UFI)
SW: Version 08.0.95gT211
Compressed Secondary Boot Code size = 786944, Version:10.1.24T225 (mnz1012 4)
Compiled on Thu Apr 21 06:08:52 2022

HW: Stackable ICX7150-C12-POE
UNIT 1: SL 1: ICX7150-C12-2X1G POE 12-port Management Module
Serial #:FEK3852Q385
Software Package: BASE_SOFT_PACKAGE
Current License: 2X1G
P-ASIC 0: type B160, rev 11 Chip BCM56160_B0
UNIT 1: SL 2: ICX7150-2X1GC 2-port 2G Module
UNIT 1: SL 3: ICX7150-2X10GF 2-port 20G Module
1000 MHz ARM processor ARMv7 88 MHz bus
8 MB boot flash memory
2 GB code flash memory
STACKID 1 system uptime is 19 minute(s) 36 second(s)
The system started at 23:27:04 GMT+00 Fri May 06 2022