Showing results for 
Search instead for 
Did you mean: 

ICX 7150-C12P does not power on. Lights do not turn on and reset doesn't work

New Contributor

Hi Ruckus support,

My ICX 7150-C12P does not power on anymore after a power outage. Lights do not turn on and I suspect the PSU is totally dead. Tried several working outlets and different power cords. Tried the "reset" button tip while plugging in power 15-20 times and it's the same. Could you please help?




Hi @aytran12 

Greetings of the day!!!

Thank you for sharing the requested information.

Based on the troubleshooting done, your ICX-7150-C12P Switch is not powering up, and when plugged into a power outlet there is no power to the Switch. Also, you tried to reset the Switch. And you confirm that the Switch is plugged into a well-known outlet/power source also tried with different cords. However, the failure persists. This Switch unit Should be RMA (Return Merchandise Authorization) in simple words replacing it.

Feel free to contact us via chat, comment you already have a post, copy the link from the post (URL) and paste it into the chat to start the unit replacement.

Please follow the below steps as shown in the below example:

As shown in the below picture, copy the link and share it via chat from the link provided below:

The below link is to contact us by chat (only)

NOTE: Please feel free to mark the post as ACCEPTED SOLUTIONS.

Please let me know if you have any queries in this regard.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

View solution in original post