Showing results for 
Search instead for 
Did you mean: 

ICX 7150-C12P Has no Lights

New Contributor

My Ructus ICX 7150-C12P Has no Lights and seems to be Dead.  All my devices connected to it are off-Line.  The Unit is plugged in, I tried unplugging and replugging, no help.  Tried disconnecting the USB cable, No Help.  Any Suggestions? Thanks Ralph



Hi @Triompo 

Hope you are doing well ! 

1-Make sure it is plugged into a well-known outlet/power source

2-Please provide us with a complete picture showing the front of the switch and that it is properly connected to a power source.

upload photo.png

Best Regards

Fernando Vasquez

Not surer how, when trying to add it said I do Not have permission to add pictures?

Hi @Triompo


You can even just copy and paste the picture into the chat.


Best regards,

Yarenis Hernández.

Technical Support Engineer | L2 TAC Wired | Lennar Home Community


I have tried that to but still get the message “You do not have permission to upload images.” Is there another way to get the picture to you?  This is getting a bit frustrating.  Is there a number I can call to talk over the phone.  Maybe the tech can walk me through some trouble shutting steps. I have tried several but not successful. It is Plugged in on a strip within my Electronics control center.  Other devices plugged in to the strip are working. Thank you