Showing results for 
Search instead for 
Did you mean: 

ICX 7150-C12 Failed to Ping

New Contributor II

Good day.

I have an ICX 7150-C12 that should be viewable in unleashed. Unleashed sees the switch enough to auto populate its info (MAC, IP, Model/Name), but is unable to complete the connection. It only shows failed to ping ICX [IP ADDRESS]. Suggest checking network.

I have reset the switch multiple times, upgraded the firmware, and tried everything I could find online before resetting once again. I am able to ping the IP through windows cmd.

Any help or guidance is appreciated. Thank you.



Hi @leonox 

Hope you are doing well!


I would like to know if you are Lennar home user , since some times the switch is running  routing  code (SPR08095d) (L3) and for this type of setups and configuration , it has some troubles for the connectivity for home users.

As I can see you are having troubles adding the ICX to the unleashed dhabsoard, I will share with you some guides to follow up

1-Made sure that the ICX is in the same subnet as the APs  run a

ICX7150-48P #show ip address

2-Unleashed side:

3-ICX configuration and steps:

4-Please ping the ICX from the unleashed dashboard I believe is in 

Admin & Services > Administer >Diagnostics> Network Connectivity page.  

Some tips I can give you is to run the following commands:

ICX7150-48P (config)#Crypto key generate


ICX7150-48P (config)#Username admin password admin

ICX7150-48P (config)#aaa authentication login default local

Then in the unleashed dashboard you have to go to switches and use the same credentials you ran as the example admin/admin

I hope this helps !!






New Contributor II

That's fantastic, thank you for the guides! I'm hoping to get into this again this weekend, though that might not happen. 


And yes, it's a lennar house. One of the first things I did was update the firmware and change it over to the sps set up. (that was... Stress inducing. I have understood the theory to do that sort of thing, but doing it was new.)

Let us the result!

I hope it worked !!! 



New Contributor II


I finally had time to check back into this process. I started looking though the app and the website connections and getting things ready to check out. 

And uh, there must have been an update or something that happened, cause everything is connecting just fine now. I can access switch info through unleased just fine. 


It also prompted me for the log in info for the switch, which was new. 


So uh, yeah. I highly appreciate the suggestions and hope they help someone else that needs them!