Showing results for 
Search instead for 
Did you mean: 

After power outage network is dropping - Switch showing disconnected state

New Contributor II

Hi, I am in a recently bought Lennar home which came with a ICX7150 switch with two access points. I have 1gbps fiber connection and it was all working great till I had a power outage and the switch rebooted. Since then my network is terrible. I searched the forum and similar issues reported and the solution seems to be to get the switch to boot up with switch firmware. I logged into the switch console (it says unleashed) and it is showing internet is connected however switch is in disconnected state.

I connected to the switch to the usbc port and was able to see the boot up sequence. Below are the messages

device 0 offset 0x0, size 0xc0000
BOOTING image from Primary

NAND read: device 0 offset 0x0, size 0x2000000
5 ecc_errors after reading 1b48000:1b49c00
iproc_nand_read_page returned 2
NAND read from offset 0 failed -22
0 bytes read: ERROR
## Loading kernel from FIT Image at 70000200 ...
Bad FIT kernel image format!
ERROR: can't get kernel image!
could not boot from primary, no valid image; trying to boot from secondary
device 0 offset 0x0, size 0xc0000
BOOTING image from Secondary

It is booting from secondary using the image SPR0809d.bin which I think is the router image while I need the switch image to solve the problem. Booting from secondary image it is asking me for login / password which I do not have. I will try the ones provided in the below post -

I attempted to tftp the switch image into primary partition, however the switch does not seem to able to ping the tftp server. I am on Windows 10 laptop using Solarwinds tftp server.

Here are my questions.

1. Is there a way to reset the login / password for the secondary partition ? I interrupted the boot sequence by pressing b and that is getting me to a ICX7150-Boot prompt.

2. Though the error is saying "ERROR: can't get kernel image! could not boot from primary, no valid image;" I am assuming the switch firmware needs to be loaded into primary partition. Am I missing anything ?

3. If I cannot get switch to reach my tftp server (running on windows 10) how do I flash the switch firmware to primary partition? Are there any other options I can try ?

I am very much stuck at this point looking for help. This clearly is not for an average home owner and requires specialized skills.  I have been trying to resolve this for weeks now and it is very frustrating Lennar or Ruckus does not offer any support besides this forum. I think these type of issues could be resolved quickly if phone support is provided. Thank you!



New Contributor II


Images did not upload to my previous reply.. Here they are.

HI @pi 

I hope you are well !

That's the CLI (command line ) for an access point 

1-I recommend that you reboot your local router to update the routing address on the network

2-Run an IP scanner or log into your local router to find out the exact IP address of your Ruckus ICX 7150 C12P

How to find my Ruckus “Devices IP address” using free applications

If via IP address is not an option I will leave you a short guide how to do it using a console cable 'usb to usb C'

How to console in the ICX-7150-C12P

4-Here is a quick guide to understand how to fix the 'routing code issue' but basically you need only need to run the following commands once you are on the command line 'CLI'  ICX-7150-C12P

Note: Hit Enter to accept each command


copy flash flash secondary 

boot system flash secondary yes 


ICX7150-24P Router>enable (hit enter to accept the command)
ICX7150-24P Router#copy flash flash secondary (hit enter to accept the command and wait: until the flash finished )
ICX7150-24P Router#boot system flash secondary yes ( hit enter to accept the command  : the switch will reboot )

How to Fix Routing code issues on Lennar Home users

Best Regards 

Fernando Vasquez

New Contributor II


I was finally able to upgrade to SPS08095g.bin for both primary and secondary partitions. I used usb to perform the upgrade since tftp was not working for me. The upgrade seem to resolve my network issues however I still have a couple of issues.

1. I am getting message TFTP session timed out continuously. How do I resolve this ?

ICX7150-C12-Switch#TFTP session timed out
TFTP session timed out
TFTP session timed out

2. When I try to log in to the switch Web UI, I am bring prompted for a Admin user and password. I tried all possible combinations provided however none seem to work. Also when I login to Unleashed dashboard I am see switch is in a disconnected state. When I attempt to connect, I get a pop up for Admin user and password. I have removed the password on the switch using the provided instructions.  Here is a picture of the unleashed dashboard showing the switch disconnected. Even though switch is disconnected my network appears to be working ok. How do I find out the switch admin user and password ?


I hope the switch disconnected state does not cause me new problems. Appreciate your help.

Thank you!


Hi @pi 

Great to hear that you were able to fix the Routing code issue ! 

1-TFTP timed out. It is not a problem. Basically it is something that is only seen by accessing the console, but basically it is looking for a TFTP server to load the configuration when there is no response Time out.

2-That the switch appears as disconnected does not mean that there is a problem, just that it is not synchronized with untied.

Here is a quick guide : 

1-Make sure the Switch is on version 8090+ later ( you are done with this since you are running 8095g )

2-Make sure the management approval is enabled

3- It would be great if you enable LLDP/RSA protocol on the switch side here is the commands: 

Device#config terminal
Device(config)#lldp run
Device(config)#crypto key generate rsa

Edit the current password and username

device(config)# username super password pass

Where the username is ’super’ and password ‘pass’

Unleashed dashboard

1-Hit Add on that dashboard 

2-Put the IP address of the ICX switch 

3-Username and password for Switch authentication that we created

To sync the data, it will take us a while, so after a couple of minutes it should say connected

Best Regards 

Fernando Vasquez 



New Contributor II

Hi Fernando,

Thank you for the instructions. A couple of follow up questions for my understanding.

1. Why is switch looking to load config from tftp server when it is not needed I think? Is this normal or now that switch is upgraded is there a command I can run stop it from looking to load config from tftp server.

2. On the switch disconnected, the instruction is to factory reset the switch. Does that wipe out my ssid configuration? I have lot of devices connected to the network and prefer not to restart.

3. Your step 3,, can I run those commands to reset admin user and password for the switch without performing a factory reset and add the switch from unleashed dashboard. Adding the switch from unleashed dashboard is asking me for a admin user and password and all I need is those credentials.

Thank you!