Showing results for 
Search instead for 
Did you mean: 

Web Management Archive funtion

New Contributor

I am using an ICX7250-24P with firmware 9.0.10j_cd1. According to the web management pdf saving a running archive from the web management console --> management --> infra is possible using the 'Save Running Config as Archive' button. The PDF references the naming convention for the archive as CX7K_ARCHIVE followed by _##  where ## is the archive number. I have set the archive size to 50 but when I try to save the running archive using the mentioned naming format I continually get the ERROR: error - the input file name does not follow the archive naming convention.  I have tried several different types of file names - CX7K_ARCHIVE, CX7K_ARCHIVE_0, CX7K_ARCHIVE_1, CX7K_ARCHIVE_00, CX7K_ARCHIVE_01.  What is the correct archive naming convention?


New Contributor III

seems you're missing the leading "I", it's icx7k, not cx7k.

at least that's how it is on 7850's running 10.0.10/20

example: ICX7K_ARCHIVE_51

edit: after my next reply, the number you use always needs 2 digits, so "01" insteaf of "1" for example.

RUCKUS Team Member

Hi Michaels2408

Thank you for reaching us

Below are few links that will help you with checking ICX archive process. Please run through them and let me know if you have tried them

From Web:

From CLI:

The error you mentioned is related to naming convention. Make sure prefix matches. Below is a snip from the document.


I hope this helps.


New Contributor III

perhaps the documentation could be a bit clearer, i also struggled with this at first. as you highlighted it says

"The archive-naming convention requires archive names be prefixed with the predefined string "ICX7K_ARCHIVE"

firstly, this is somewhat incorrect, it needs to be prefixed with "ICX7K_ARCHIVE_" (note the trailing underscore), the web manual omits that part.

while you can deduce from the example the the "archive naming convention" is 2 digits from the cli docs, i never found this mentioned in detail. also it needs to be exactly 2 digits, so you might need to prefix it with 0.

2 bonus items:

the cli guide mentions a "golden archive", and while i can most likely guess what that means it's not to be found in the guide:

the web guide like to call it "archive-naming convention" with a dash between archive & naming, cli says "archive naming convention" without a dash.


RUCKUS Team Member

Hi Inphobia

Ack and Thanks for providing your feedback.