cancel
Showing results for 
Search instead for 
Did you mean: 

ICX 7150 missing address command

Jerry
New Contributor III

When I try to add an IP address (IP Address xxx.xxx.xxx.xxx. xxx.xxx.xxx.xxx) I get invalid command for Address.

Looking in the menu of the IP command, there is no Address command listed.

How can I add an IP Address if there's not Address command?

Thanks.

1 ACCEPTED SOLUTION

Jerry
New Contributor III

With all the information you've given me, I was able to install the 8080f image and set the IP address, subnet, etc...  Now I just need to update to the latest firmware.  Thank you so much for all the help.

View solution in original post

13 REPLIES 13

BenBeck
Moderator
Moderator

We would need some more details to help here. Could you share a screenshot or log of the steps you are taking? Otherwise I would advise opening a support case (see my signature). 

 

 

Ben Beck, RCNA, Principal Technical Support Engineer
support.ruckuswireless.com/contact-us

Jerry
New Contributor III

Here’s the whole story.

I wanted to upgrade my switch to the latest firmware but the current firmware was too old.

So I upgraded the firmware on an ICX 7150 from 08.0.61cT211 to 08.0.90jT213. See below.

 

Jerry_0-1661263623731.png

 

 

After the upgrade completed, all the IP information was gone.  IP Address, Subnet, Gateway, DNS.

I tried to add it by entering the IP command and this is what I get.

 

Jerry_1-1661263623732.png

 

 

When I look at the IP menu, the Address command is not listed.  See below.

 

Jerry_2-1661263623740.png

 

 

Why did the upgrade strip the IP info and how do I add it back?

pmonardo
New Contributor III

Did you upgrade from switch code to router code? You are now running router code on 8090.

You need to configure a VE interface, something like this

interface ve 1
ip address 192.168.1.2 255.255.255.0
!

and have a default route

ip route 0.0.0.0/0 192.168.1.1

BenBeck
Moderator
Moderator

It looks like you likely switched from switching code (allows a single global IP address) to routing code (where you address VEs or interfaces). Notice the code you are running now is SPR08090jufi.bin ('show flash' to check). The SPR denotes routing code. There is also a switching image which would have a name such as SPS08090jufi.bin (SPS denotes switching). What likely happened is you switched from an SPS image to an SPR image. The global IP address command is not valid in SPR image, therefore it failed to parse at bootup and the command is not available. To get yourself back up and running, you can do something like this:

conf t

int management 1

ip address <address> <subnet-mask>

You can then connect a laptop/computer to the mgmt port to gain connectivity and copy over the switching image (assuming that is what you want to run). Just make sure it is on the same subnet as what you configured. If you need any help with this, please feel free to open a support case (see my signature).

 

Ben Beck, RCNA, Principal Technical Support Engineer
support.ruckuswireless.com/contact-us