Showing results for 
Search instead for 
Did you mean: 

R300 not joining ZD3050

New Contributor II
Greetings, people!

As the title says, I'm having an issue connecting an R300 AP to our ZD3050. I've used the following methods in configuring Ruckus access points, and they've worked well with our R500 and R310 acquisitions (meaning they were able to join ZD without any problems--except for one time. I'll also include that here). Without further ado, here's what I did (except otherwise stated, all of these were done via GUI):

Method 1:
1) Go to Management, enable controller setting and set ZD's IP address manually.
2) Go to Internet, change VLAN to the one we're using. Reboot.

--> This doesn't work. After 30 minutes the AP's power indicator is just a steady green--and nothing else happens.

Method 2:
1) Go to Internet, manually set the AP's IP, netmask, gateway and VLAN. Reboot.

--> Same as above, doesn't work.

Method 3:
1) Set ZD's IP manually.
2) Set AP's IP, netmask, gateway and VLAN manually. Reboot

--> Doesn't work.

Method 4:
1) Set the AP's IP, netmask, gateway and VLAN manually.
2) Access AP's cli, manually set ZD's IP address there. Reboot.

--> Doesn't work.

When I was manually setting the AP's IP, I accessed ZD's cli as well and pinged that IP from there. ZD was able to get replies from the said device. I also logged into the AP's cli, pinged ZD from there and got replies. I even tried configuring a spare R500 AP and it was able to join ZD without a hitch.

I was wondering if it was because of the AP's model, but I've been told that R300s should be able to join ZD.

Alright, onto that one problem I've encountered last time. There was this one R500 access point that refused to join ZD. It was discovered that the AP's country code was locked to use the US country code. Our supplier had to contact Ruckus support to help unlock it.

Now, as I  was configuring the R300 AP, it was stated in the manual that I should change the country code to the one used by ZD. But upon checking the dropdown for that, it was greyed out and unclickable. I've seen from that I could use the 'set countrycode' command to manually set the parameter. Though running 'get boarddata' also showed me that the country code is fixed. In that post, setting the country code failed, but when I tried I was able to set it to the one our ZD was using (I was honestly not expecting that to happen). Even visiting the AP's GUI showed me that the country code is now the same as our ZD's (still greyed out and unclickable, though). But the AP is still not joining ZD even after that. I've already checked, and we've managed to tick off most of the culprits--except for the country code.

Apologies for the very long post, but there you go. I've tried everything that we've been taught, and the things that I've seen from the support community. It just baffles me how I was able to join other AP models with the same procedures, but not this R300 one. I'm guessing that even if I managed to change the country code on the AP, it still isn't enough. ZD isn't even logging anything about the R300, but I can ping the said AP from our controller.

Additional information:

R300's current firmware:
ZD3050: build 189

Thank you for any help/assistance with this.


No problem, I'm happy to help you! 🙂

Esteemed Contributor II
Thanks Erjohn.  The logs on your ZD's Monitor::Access Points page should have held some clues for you too mdtowne.

I've been checking the All Events tab in our ZD (that's where we found out the country code error last time). I'll give it another go next week and check other log output (for additional documentation on our side). I have a question, though: there's no other way to add the AP aside from downgrading the ZD firmware version, right? Configuring the AP's a no-go, and there's nothing in ZD we could tweak or set to allow it to recognize the AP?

Have you got support with your current supplier. Have they not kept you up to date with what firmware versions are possible. There is a possible way around this

We still have support from our current supplier, yes. But I can say that it's not about them not keeping us up to date. 😄 If there is a way other than downgrading the firmware version, I'll happily look into it, though.