Showing results for 
Search instead for 
Did you mean: 

Guest Portal not working on 5.2

New Contributor II
After upgrading our Virtual SmartZone and all AP Zones to 5.2, we ran into an issue with the Captive Portal on our Guest SSID's no longer working on R730's and R610's.  I don't know if any other model had the same issue, but after downgrading the AP firmware back to 5.1.2, Captive Portal was working again.  We had tried factory resetting the AP's, moving them to a different controller on same firmware, deleting and re-creating the SSID's, etc.

Support is working to replicate the issue, but wanted to make sure people knew what we ran into in case you see it as well.

Hi Foster,

What you are referring is the AP Zone firmware change, which is different than vSZ downgrade.

You have explained it correctly though!

So if anyone wants to change just the AP version (AP Zone firmware), procedure given by you is correct. Or if want to downgrade entire controller, procedure given earlier by me is correct.

Thanks for highlighting!

Syamantak Omer

Syamantak Omer

RUCKUS Networks, CommScope!

Follow me on LinkedIn

RUCKUS Team Member
Hi Everyone,

Did you get the update about the nature of the issue? This is a known defect on 5.2  build 699 with redirection issue on Guest/WisPr portal and is resolved in build 5.2.1 available at Ruckus website or you would need to disable lighttpd on the AP's by using AP CLI script. The command would be "set lighttpd disable".

If any concern or query please let me know. 

Best Regards
Vineet Nejwala

Hi Vineet .

What is the command for?


Hi Jeronimo,

The command is to disable Lighttpd i.e a light weight HTTP Server that will be providing all front end Web services in the AP. It was observed that in 5.2.0 lighttpd process was starting and stopping (crashing) as observed in the logs.

The usage of this command is as below, if you are having similar issue you can execute this command on one of the AP and test with a client :

rkscli: set lighttpd
Usage: set lighttpd {options}
-> {enable|disable}
-> debug {level}
-- set LIGHTTPD debug log level (0-2), or enabling/disabling lighttpd
0 = log disabled.
1 = basic debug log enabled.
2 = detail debug log enabled

rkscli: get lighttpd status
- Lighttpd status:
process state: running*
debug log level: 0
- server status/counters:

Best Regards

Thanks Vineet.

It's very helpful.