Showing results for 
Search instead for 
Did you mean: 

ZoneDirector 1200 Firmware Upgrade

New Contributor II

Hi all,

I have a big project coming up next week to upgrade firmware of 2 x ZD1200 in Smart Redundancy mode, our current firmware is build 29.

Please could someone advise the upgrade path to the latest version, as I'm struggling to find our current build in newer versions.

We are going to be using a mix of R500 and R510 internal APs and T310 external APs.

Also, I tried to upgrade the firmware on the Active device last night but it just looked like it froze when trying to upload the .img firmware file, I was trying to use firmware version - maybe this was wrong which is why it didn't work? But I tried to search for the issue, and tried different browsers (Firefox, Edge, IE, Chrome) but they all did the same thing, gave no upload progress and did nothing for about 30-40 minutes.

Thanks for any advise!


Hi @kuk_support ,

It is strongly recommended to do upgrade locally.

Over the VPN, due to encapsulation/encryption overheads, some times file transfer may not happen completely from the remote machine to ZD and due to that firmware upgrade fails.

Syamantak Omer
RUCKUS Networks, CommScope!
Follow me on LinkedIn

Hello @syamantak_omer - Thank you for the information.

I was connected to the ZD primary controller, and trying to upload the firmware file from the same network as the controller.

So, my VPN connection was only being used to connect to the controller not actually send the firmware file from my local machine.


As long as source system of the upgrade file and ZD can reach each other without much data fragmentation, upgrade should be successful.

I usually suggest customers to login into any RDP server or any machine which is local to ZD or vSZ/SZ network, run the upgrade from that machine. This makes communication between browser to controller local and no additional overheads/network hopes.

Syamantak Omer
RUCKUS Networks, CommScope!
Follow me on LinkedIn

When you open upgrade window on ZD, transfer happens through your PC, it means -- over VPN connection. And it may not work. It's always better to do this locally, as local LAN and VPN over Internet have very different reliability, and file can be easy corrupted over Internet.

So it was actually good  that upgrade attempt failed - otherwise, if you would be able to write corrupted image into ZD, most probably next step would be RMA.