cancel
Showing results for 
Search instead for 
Did you mean: 

How can I enable IGMP V3 on a R550 Unleashed ?

Truman
New Contributor II

Hi,

I did not find any setting on the unleashed master for activating igmp v3. Is there a possibility to enable multicast and igmp v3 ?

I have installed Unleashed 200.14 firmware on my R550 Master and also on the other ap´s.


Thank you in advance for your help. 

11 REPLIES 11

Parik_MN
RUCKUS Team Member

Hello @Truman

Below are the command line to run AP CLI commands from Master AP.

ruckus# ap-mode
You have all rights in this mode.
ruckus(ap-mode)#

You could also run remote ap cli command from Debug mode to execute the command on all connected APs.

ruckus(debug)# remote_ap_cli -A "set qos igmp_query v3 enable"

 

Regards,

Parik

 

Truman
New Contributor II

Perfect, thank you.

Truman
New Contributor II

@Parik_MN :

After my HomeKit implementation is still not working, I checked again the igmp status and for whatever reason, it was again disabled. How could that be, that it is disabled, after I enabled it by using the cli commands, specified by you ?
I have general HomeKit problems, since I exchanged all the access points from another brand to Ruckus. 
Is there any guideline, how to get Apple HomeKit working with wireless connected components ?

Thank you in advance for your answer.

Parik_MN
RUCKUS Team Member

Hello @Truman,

 

Looks like AP specific config is not persistent. Please run below commands from Master AP to retain the config post reboot. In addition to IGMP, I have added commands to disable directed multicast and broadcast which disables the packet conversion from broadcast/multicast to unicast.

ruckus> enable
ruckus# config
ruckus(config)# ap-group "System Default"
ruckus(config-apgrp)# qos igmp-query v2
ruckus(config-apgrp)# qos igmp-query v3
ruckus(config-apgrp)# no lan 1 qos directed-mcast
ruckus(config-apgrp)# no lan 2 qos directed-mcast

ruckus(config-apgrp)# exit

ruckus(config)# wlan <wlan_name>  #Make sure to enter the right WLAN name.
ruckus(config-wlan)# no directed-threshold
ruckus(config-wlan)# no qos directed-mulicast

 

Regards,

Parik

Truman
New Contributor II

Hello @Parik_MN,

thanks a lot again for the detailed instructions.

Everything worked so far, besides the commands:

ruckus(config-apgrp)# no lan 1 qos directed-mcast
ruckus(config-apgrp)# no lan 2 qos directed-mcast

and

ruckus(config-wlan)# no qos directed-mulicast

For this 3 commands I am getting a "The command is either unrecognized or incomplete. To view a list of commands that you can run  from this context, type '?' or 'help'." message.


Regards,

Christian