Showing results for 
Search instead for 
Did you mean: 

3 unleashed R310, client stickiness

New Contributor III

Hi, I have 3 R310 unleashed AP’s, connected by wire (no roaming).

two are on the ground floor (attached to ceiling), one on the second floor, facing down.

when I am on the first floor, my clients (iPhone) keep connecting to the R310 attached on the ceiling of the floor below (ground floor). Network speed on 5ghz is then around 70mbit.

when I disable the AP on the ground floor, the clients connect to the one on the second floor, resulting in much higher internet speeds (150mbit).

I tried lowering the transmit power on the ground floor in order to get clients moving to the AP upstairs, but I need to lower till 1/4 in order to let clients switch to the AP on the second floor. This also results in too limited coverage on the ground floor and garden.

any tips what I can do?

thank you


New Contributor III

Ok, so I have experimented a lot and finally configured my 3 r310’s as follows:

  • Separate ssid’s for 2.4 and 5 GHz
  • Fixed channels 1,6,11 on 2,4
  • Fixed channels 36, 44, 52 on 5
  • Channel width on 5 ghz to 40mhz
  • BSS-minrate on 12 (both ssid’s)
  • OFDM-only mode enabled (both ssid’s)
  • 802.11k enabled (both ssid’s)
  • 802.22r enabled (both ssid’s)

still a little stickiness on some devices, so also enabled:

  • 802.11v smart-roam level 3

now works perfectly!

No client stickiness and no devices connected to the wrong AP’s.

As an advice for others, it is very beneficial  to name your AP’s based on their location, and validate if the clients are connected to the most logical (nearest) AP. All my devices have connectivity level 'excellent' right now.

If it's helpful for others, I am willing to share all the SSH commands. Please let me know if needed.

Any tips or follow-up advices are welcome!

Two more questions: do I need to disable background scanning when using fixed channels? And how can I check in the logs if DFS is triggered?

View solution in original post


Contributor III

Dear Jan,

Please try to disable lower data rates, it should help in making the client to connect to nearest AP.

Hope it helps !!!


Abilash PR.

@abilashpr thnx! But how to do that? By enabling 11n/ac mode only? Or via SSH?

and would enabling 802.11r and 802.11k be useful in this case?

New Contributor II

802.11r & k can be helpful if you clients support them (the iPhone does) - it allows the connection to the new AP to be setup before losing the connection to the old AP so the transition is faster/seamless.  This way as the client changes APs (and channels because each AP should have its own channel to minimize interference) it does the smallest drop in performance during the changeover.

New Contributor III

I would suggest first assessing what the dBm of each AP reported by a WiFi scanner as you walk about on the second floor.  If the values are very close (say within 20 dBm) between the 2nd floor and ground floor APs, then I would consider relocating the APs to minimize overlap.

Then I would experiment with either setting bss-minrate, say to 12 (which means disallow connections if the data rate is < 12) and/or smart-roam, which will deauthorize clients if another AP sees the client with a much stronger signal.  You can do a web search for Ruckus articles on these settings.