Showing results for 
Search instead for 
Did you mean: 

WAPs all down after power outage - attempts to console (Mac) have failed

New Contributor

After a power outage, my switch stopped working. We have a connection from our ISP router, but both access points have all lights off. The switch has two lights on: SYST/amber, and PWR/green.

I've restarted the switch and also tried the reset button while replugging it in, but that left the lights blinking endlessly.

After installing the two drivers listed in this article, I've connected my Macbook Pro with a type-C cable to the switch, and opened Terminal. I followed the steps listed in the post, as well as the different instructions in the video the same article linked to, but neither approach worked. No device appears to be detected - using the prompts doesn't display any additional connection.

Strangely, while attempting to console at one point earlier in the day, I noticed the WAPs were on, but the connection was weak. After leaving that to do its thing for a few hours, I decided to restart the device to give it a good bootup. Unfortunately, that brought me back to square one: orange SYST light, green PWR, no connection, access points all down.

I've had power outages before in this house and the reset has always worked. Please advise, thank you.



Hi @gmasciopinto 


Greetings of the day,


Based on your description, it seems that you switch has green and amber light which means that your switch is stuck in boot mode.


If the resetting process doesn't work we need to perform software recovery process.


Here is the quick guide to perform software recovery.

How to perform a Software recovery on an ICX7150 switch


Ruckus ICX Recovery Load boot code from boot monitor


Please share the screenshot of the error you are getting while following the steps.


Best regards,


Lennar Home Community

I understand I need to do a software recovery, but as I mentioned in my first message, I could not connect even though I followed all instructions. I can't get it to console so I can't even start the recovery steps. 

I have a Mac so that video you also linked in your response doesn't apply. 

Please advise, thank you.

Hi @gmasciopinto 


Please share the screenshot of the error you are getting while following the steps.


Also please provide an image/photo where you are trying to connect via console

 from ICX 7150 - C12 P (USB type C to  USB ) to PC. Before uploading the photos please login to the RUCKUS account and you can upload the image.




Best regards,


Lennar Home Community

Last night both WAPs turned on with green lights BUT any device connecting to the Wifi cannot load anything (websites/apps timeout). I can select it as an option in the wifi list (with full signal), but it isn't usable. As you can see in this photo of the switch, STAT, SYST, and PWR are green.


 Does this mean there is a different problem? 

What I've done so far:

1. I installed the drivers.

2. I opened Terminal and ran the command "ls /dev/cu.*" and noted the list of 3 results.

3. I connected my Macbook to the switch via type-c USB (as shown below and the photo above), and ran the command again, but the same 3 results show.


Screenshot 2023-06-28 at 5.48.46 PM.png

Please advise, thank you for your help.