Showing results for 
Search instead for 
Did you mean: 

Slow Download Speeds R710 Unleashed

New Contributor
Strange issue with R710 on latest unleashed firmware. Upload speeds consistently incredible on both laptop and phone but downloads even from 5 ft away never go over 200 but stay consistent through 3 thick walls. Speedflex on android shows 550 up 550 down to AP. Iperf reflects results. Cable shouldn't be the problem as I have plugged my laptop on it and gotten the gigabit fiber speeds I should be getting. I have factory reset it countless times set everything to auto and tried manually setting the bands and channel width, am I missing something? Any help would be appreciated.Image_ images_messages_5f91c3fe135b77e24790df97_43e5db9b2eca36b81d35b46dbdb8f876_RackMultipart20190818868831y92-dc568500-96c2-4610-9714-84fb1bdd684c-743324385.jpg1566155318
379 REPLIES 379

So using R710 and ZD1200 with latest FW on all doesn't impact speed? Haven't had time to test that yet.

No, I’m sorry. I had the zd1200 with 2 r700’s. Now I’m using an r710 and an r720, both unleashed, no zone controller. Speed is less than half...

Hi All!

Maybe I found a resolution, or idea for the problem.

Test environment:

500/50Mbps DOCSIS3  Internet Provider Modem in Bridge mode to Pfsense 2.4 

Ruckus R720 with POE+ 60watt

Unleashed Settings: 

Support for 802.11d disabled

Radio Resource Management : disabled

Background Scanning : disabled

5GHz AUTO channel 44 fixed

2,4 GHz disabled (I don’t need it)

Poe: AT+ set manual 

WPA2 OPEN with Password


Iphone X

Macbook Pro 2018

Samsung galaxy s10

Dell XPS Windows

Ruckus R720 Unleashed

Sorry for my english!  I tried all firmwares from 200.6 to 200.8 but 200.6 was the best from all.

200.6.10    D 400-450Mbit / U 50Mbit 

200.7.x.      D 160-210Mbit/ U 50Mbit (only dell XPS was perform to 420-450Mbit download speed)

200.8.10     D 160-210Mbit / U 50 Mbit (only dell XPS was perform to 420-450Mbit speed)

6 Day working and then I found the bug (maybe).

You need to enable MESH and ARP broadcasting filter! Reboot your AP before testing!

(You don’t need 2 AP’s for enable Mesh) 

And NOW: 

Iperf3 D 450-480 Mbit 

200.8.10     D 480-495 Mbit / U 50 Mbit !!!

The overall wifi coverage with this “hack” is not so good as with the 200.6 firmware. But maybe Ruckus people can find the problems with the new information.

The problem now is for ruckus to be able to reproduce the problem at their labs which they can not seems to reproduce. So I had one of their techs log on my site and helped them perform iPerf 3 tests ... anyway Had to send them support logs and so far no word... that was about 2-3 weeks ago.

How difficult can this be?!  Just use a single AP (I have an R710 and an R720) in Unleashed mode and test it with a single client (MacBook Pro in my case). You'll see immediately that the internet speeds are between 1/4 and 1/2 of what the internet speed should be.  Super simple to replicate.  Believe me, I've tried everything and keep getting this same result.  How difficult is that to fix?!  This has been going on for over 6 months!!!!  I bought a $19 wireless AP and it outperforms both my R710 AND my R720.  How pathetic is that?!