Showing results for 
Search instead for 
Did you mean: 

Ruckus unit died

New Contributor


Our ICX 7150-C12P switch unit has died and will not reconnect. I have unplugged and plugged it back in, reset the main house breakers, and tried to reset and it does not power on or show any signs of life. Our unit on our ceiling also does not have any lights (green or orange) and all of our units (ring/kevo) that usually plug into the ruckus do not have life as well. We have not had any surges or power outages. The unit has not been moved from the original location that it was installed when the house was originally built. 





Thank you for the details provided, please connect the ICX7150 Switch directly to the power outlet and if still not responding, please share a panoramic image to confirm the ICX7150 Switch is no longer powering up.


Best regards,

Yarenis Hernández.

Technical Support Engineer | L2 TAC Wired | Lennar Home Community

New Contributor

How do I add a picture? When I try to add an image it states "you do not have permission to upload images" in big red text. 

New Contributor


Nevermind it allowed me to this time. The above picture is the ruckus plugged into a reliable power source with no power to the system.

Hi @SMR 

Hope you are doing well! 

Based on the troubleshooting done, and you confirm no power on, on the unit and is totally dead (no lights at all , This unit Should be RMA (return merchandise authorization) in simple words replace it.

Feel free to contact us via chat  comment you already have a post, copy the URL of this post and paste it into the chat to start unit replacement process.

Best Regards 

Fernando Vasquez