Showing results for 
Search instead for 
Did you mean: 

Ruckus switch not working

New Contributor

I have a Lennar home and been using the Ruckus Switch for 3 years.  I noticed that the switch keep power cycling for two days and I couldn’t connect to the internet.  After two days I noticed the APs are completely powered off and I can’t connect to WiFi.  Any ideas on what happened and how I can get APs back online?  The main unit is powered on but no way to connect.





Thank you for contacting RUCKUS Lennar Home Community.

Hope you are doing well!!!

Thank you for the information you shared.

As per the case description, I could understand that your RUCKUS Setup is not working and Access Points have no power.

Could you please let us know the answers to the below queries to assist you better?

1. Was this working before? If it worked before, was there any power outage before you started facing this issue?

2. On your switch while it's plugged into the outlet, do you see any lights on? (Amber or green) Please let us know which lights are on. (Please refer to the below picture and share a picture of the same, showing the light status and the FULL Switch panel cable connections to the Switch ports)

3. Is your Internet Connection from the Internet Service Provider (ISP) stable and working? (You could check this by connecting to your local router Wi-Fi or from an ethernet cable from Router to a laptop/PC).

4. May I know how many Access Points are connected to the Switch? 

Please help us with pictures of your ICX-7150-C12P Switch showing the status of the lights and cable connections to the Switch ports. 

Before uploading the photos please log in to the RUCKUS account and you can upload the image.

Please let us know the answers to ALL the above queries or let us know if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.


Hi Imran,

Please see the answers to your questions below.

1.  The system was working just fine before it started power cycling.  There was no power outage prior to it malfunctioning.  I have it connected to a UPS and the battery power kicks in if there are any power issues.

2. I do see a green light and an amber light on the switch.  The pictures are pasted to this email.

3. My internet server is stable and working fine.  I’ve had to connect my devices to the ISP directly since my switch isn’t working.

4.  I have 3 access points connected.  All three have no power and none of the lights for all 3 APs are off.  There are no lights at all so I didn’t include a picture.

Please let me know if you need any other information to diagnose the problem.





Thank you for the detailed information you shared.

As you mentioned and we can see from the picture you shared, there are lights on PWR and SYST, if there is an amber/orange light on the "SYST" and a green light on the "PWR" on the Switch (as it is in the below picture). Meaning the Switch is stuck in the boot mode.

Basically, due to the power outage/ power spike, the switch went to a state that we call ‘boot mode’ that is not able to boot up properly. 

Please follow the below steps to fix this issue:

First we will try to reset the Switch as described below:

1. Please try to disconnect from the Power outlet the ICX-7150 and reconnect.

2. Please try to press the reset button using a paper click or a small stick 

  • Remove power from the switch.
  • Press and hold the Reset button while applying power to the switch.
  • After all the system LEDs flash amber, release the Reset button.

Below is the Guide and Videos link for your reference:

Video link:



IF RESET DOESN’T WORK: Please follow the below steps.

If the reset does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

Below is the Guide and Video Link to perform the Software recovery process:

Please refer to the below guide and Video link:

Video Link:

Please let me know if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

Hi Imran,

The reset did not work.  I tried to do a software recovery but keep getting an error message when downloading the firmware.  I have had this happen in the past where it was stuck in boot mode.  I was able to speak to a Ruckus tech support specialist and he was able to remote into my computer and update the software.  He mentioned it took a lot longer than normal due to some corrupt files.  Is there an option to have remote support?  

I also spoke to Lennar and they mentioned that the Ruckus switch has a limited lifetime warranty and that I should submit a ticket on the community board.  Is it possible that I have a defective switch as this has happened before?   Please advise if there’s any remote assistance available.  Thank you.