Showing results for 
Search instead for 
Did you mean: 

Ruckus R720/R710/R610 Unleashed half speed download

New Contributor II
Dear Ruckus, I have invested enough money to get fast and seamless internet on my APs. Not only did I recommend Ruckus Unleashed to many of my friends who wanted a fast and stable internet connection, and they also bought your points. But it is not, stable - yes, seamless - rather yes, fast - no. I carefully read all the similar problems in this forum over the past and did not find a single solution to the problem with half speed internet. Some offer a downgrade to 200.4, some Standalone. But this does not solve the problems if you have a few modern points with Wave 2 (which have the earliest firmware 200.5) and there are not so many to buy ZD. But what is more frustrating is that all the solutions are offered by users, not Ruckus himself. Even the timing of its decision is not defined. Recently a new firmware 200.8 was released, but this problem is still not solved. Because it’s really a problem when an AP for $40 gives Internet download speed up two to three times faster than at a point for $1500. Just tell us you are solving this problem or not? And when is the result possible? If it drags on for a long time, it’s easier to sell all my APs on eBay and switch to another vendor.

Related posts:

New Contributor II - same issues on my Unleashed network (2xR710, 2x610, 1xR720, 1xH510)

Issue is there, but not as bad as 200.7.x...right now just sticking with performance was 200.4.x.... hoping they will fix this issue...already sent them test support logs.

New Contributor III
I also have the same problem with r510 and h510 setup

New Contributor III
Any fixes? I upgraded the firmware on my R720 and my tenants sent me dozens of text messages when I updated to the latest firmware. Doe the R730 have this issue?

New Contributor III
I spent 4 hours with Ruckus support with a new install of 4x R720's with latest firmware.  Not easy to explain to client why these new Ruckus AP's get HALF the download speed of the Ubiquitis they replaced.  NOTE: In testing, the problem appears to be with how it handles WPA2 encryption.  Created test open SSID (no encryption) and the speeds doubled - although still not close to the speeds of a wired connection.  SO DISAPPOINTED to read that this issue is not so recent and they have been unable to fix the issue after many months of complaints.  Any word if this has to do with the change of ownership (Arris, now CommScope)?  Not only does this compromise the integrity of Ruckus - it puts integrators in a really bad position.  I cannot possibly do another installation with Ruckus equipment until I am assured this problem is fixed.  I can't believe I actually have to post this.  I won't even get into the issue of this latest firmware breaking PoE negotiation on R710s (now bumped to 802.3af from 802.3at.). What is going on at Ruckus engineering??