Showing results for 
Search instead for 
Did you mean: 

Ruckus R510 Access Point Not Turning On. Help!

New Contributor

Didn’t get a reply to my 11/26 thread. Really need my wifi back up. Does anybody have a fix for a power outage situation where my switch still has power but the access points all turned off. The lights don’t come on. Tried to reset and unplug POE. Any suggestions? 


Hi @ruffwill 

Hope you are doing well! 

1-On your switch while it's plugged into the outlet, do you see any lights on? (Amber or green) Please let us know which lights are on? 



2-Make sure it is plugged into a well-known outlet/power source

Best Regards 

Fernando Vasquez 

@Vásquez_Fer there is a yellow light on next to SYST and a green light next to PWR. 

Hi @ruffwill 

Basically, due the power outage the switch went to a state that we called (boot-mode) that is not able to boot up properly. 

That does not mean is broken or need to be replace 'in some cases'

1-Please try to disconnect from the Power outlet the ICX-7150 and reconnected.

2-Please try to press the reset button using a paper click or a small stick 

  1. Remove power from the switch.
  2. Press and hold the Reset button while applying power to the switch.
  3. After all the system LEDs flash amber, release the Reset button.

Video link:

If that does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted so in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

3-We need to access (physical) using one of the cables to the ICX-7150C12P mentioned on the below guide: 

How to console in the ICX-7150-12cp

Once we are there, we can try to boot up the unit using the following commands: 

Boot_primary or Boot_secondary 

If that step does not work Software recovery needs to be applied

Here is the guide:

 Video Link:

Best Regards 

Fernando Vasquez 

@Vásquez_Fer we tried those solutions and it didn’t not work. Holding down the reset button didn’t turn the lights amber. 

We are now trying to install the software physically but it is not working. Is there someone we can speak to by phone?

Hi @ruffwill 

Effective November’2022, ‘Ruckus Support for Lennar Homes customers will no longer be handled by phone or email. We will be exclusively supporting customers via this community forum support model.

If you need something to be clarify on the process, please let us know or send us a screenshot where you are stuck 

Best Regards 

Fernando Vasquez