Showing results for 
Search instead for 
Did you mean: 

Ruckus ICX7150-C12P no longer powering WAPs, Smart Devices, etc...

New Contributor

I have disconnected the power, let it sit for an hour and plugged it back in hoping it would reboot, but it is no longer powering any of my homes smart devices.

My wife and I both work form home and depend on the WAP to reach our home offices.   So, this is a critical issue that effects our ability to provide for our family.  

Your quick response will be greatly appreciated.


New Contributor

Reading other post and it sounds like it will need to be replaced.   Please advice me on how to make that request.

New Contributor II

Hi Randy,

Are you in a Lennar home that had a power outage which took out your Ruckus devices? Our Verizon internet continues to work but all the Ruckus units are dead on all floors. Unplugging power did not work. Is that your issue as well? What did you learn as a solution? Thanks!

New Contributor

Yes.  I am a Lennar Home Owner, but it wasn't caused by a power outage.  It just stopped sending power to the connected devices.   I've tried a power reboot multiple times, but nothing has changed.

No solution yet

Bummer, I hope you get it worked out. I will post here tomorrow and see if someone from Ruckus replies. Do you know which contractor would even be involved with this kind of issue. I suppose it depends on where you live. We are in Maryland.