Showing results for 
Search instead for 
Did you mean: 

Ruckus ICX 7150 not working

New Contributor

Post the power outage today, my ruckus wifi is not working.

there is a light in the ICX switch but no power light in all the three APs.

My internet is working thru my provider.

enclosed are the pics of the ICX swithch and API


  • IMG_3666.jpeg



Hi @roopeshgupta 


Thank you for contacting RUCKUS Lennar Home Community.

Hope you are doing well!!!

Thank you for the information you shared.

As per the case description, I could understand that your RUCKUS setup is not working after a power outage, and Access Points do not have power.

Please note, I see from the picture you shared, seems like the ethernet cable which is coming from the Router or Modem/Router combo is plugged into the wrong port on the Switch panel. It must be plugged into any 1 in-12 ports as shown in the below screenshot. Please unplug the ethernet cable and plug it into the correct port.

As I can see from the picture you shared, there are lights on PWR and SYST, if there is an amber/orange light on the "SYST" and a green light on the "PWR" on the Switch (as it is in the below picture). Meaning the Switch is stuck in the boot mode.

Basically, due to the power outage/ power spike, the switch went to a state that we call ‘boot mode’ that is not able to boot up properly. 

Please follow the below steps to fix this issue:

First, we will try to reset the Switch as described below:

1. Please try to disconnect from the Power outlet the ICX-7150 and reconnect.

2. Please try to press the reset button using a paper click or a small stick 

  • Remove power from the switch.
  • Press and hold the Reset button while applying power to the switch.
  • After all the system LEDs flash amber, release the Reset button.

Below is the Guide and Videos link for your reference:

Video link:



IF RESET DOESN’T WORK: Please follow the below steps.

If the reset does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

Below is the Guide and Video Link to perform the Software recovery process:

Please refer to the below guide and Video link:

Video Link:

Please let me know if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

The router cable was plugged in where it was in the picture before power outage and was working fine. Based on your suggestion i plugged that wire in port 1-12 and tried to reset it. It was constantly in the mode where lights were flashing.

then i plugged the router cable again in the port where it was and again did the reset and this time it worked. 
I remember previously also when a technician came to home and tried moving the cable to port 1-12 it didn’t worked. This is making me think whether there is any issue with the switch itself and does it need replacement as it gives problem everytime when there is power outage

Hi @roopeshgupta 


Thank you for the response and the update.

Please note, this issue happens repeatedly when your Switch is on a old software version and to avoid the same we may need to upgrade your RUCKUS ICX-7150-C12P Switch to a new stable version.

We will check your current running version on the Switch to proceed with the upgrade, please follow the below steps to check the same.

Please follow the below steps and help us with the queries,

1. To check this issue, we must identify the ‘current’ IP address assigned by your local router to the switch ICX-7150-C12P

I will leave you a guide on how to perform an IP scanner on your local network to identify the switch IP address very easily. 

How to find my Ruckus “Devices IP address” using free applications:

2. Once we identify the IP address of the switch proceed to access remotely to the device “Command Line” 

How to remotely access to 'ICX 7150-C12P' or 'access points' "Network devices":

If you can access the Command line should look like this:

ICX7150-C12 Router> OR

ICX7150-C12 Switch>

Please enter the below commands once you log in to CLI and share the output.

Note: Hit Enter to accept each command 


show version

show flash

Please share the output of the above commands or share the screenshots if stuck at any step or error (if any) and let me know if you have any queries in this regard.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

Hello - below is the screen shot for the response from the commands. Please let me know if this is what you were looking for and the next steps