Showing results for 
Search instead for 
Did you mean: 

Ruckus 7150 not powering

New Contributor


We have Lennar home with Ruckus network. I need assistance, my Ruckus 7150 switch it is dead and all Status lights and POE plugs are not powering APS. I have tried everything In messages posts including resetting it 15-20 times, unplugging it and replugging to different power outlets, connecting laptop to switch, but nothing works.  I am not familiar with rebooting the switch and can’t get it to appear in laptop with C usb connection to try. 

Can someone help on how to get a replacement and/or recommend a different brand switch with POE compatibility with Ruckus APs?

I appreciate your assistance,



RUCKUS Team Member

Hi Tpad 

Thank you for reaching us

  • Could you please help us with picture of front panel of the switch ?
  • Could you also help us with picture of LED lights on the AP ? 
  • Do you have access to switch using console ? 

Could you please try the below software recovery on the switch once and see if this helps you to recover the switch 

Link to software recovery:

Below is the datasheet link to 7150 switch series :

From the above datasheet below are the two models that will help you with PoE 


You can also run through the datasheet and choose the switch based on your requirement. 

I hope this helps.


New Contributor

It was working fine but approximately a month ago it stopped. The switch and Ruckus aps are not working. We have Xfinity internet service and it is working but Ruckus switch Status lights and Poes are not powering Aps. I have reset it 15-20 times as noted in Lennar Ruckus community chats and nothing has worked. I attached my laptop through C usb but Ruckus does not function on laptop to try to attempt reset. I have reviewed several chats and talked with Lennar neighbors that this Ruckus switch is causing a lot of similar issues and most are frustrated with lack of Ruckus support to address the issues.  Can you help address power issue’s maybe in-person at your Sunnyvale, CA business address because my tech skills are limited and over the phone or on-line support will not work. I believe my Ruckus is under warranty, so I prefer that you just send me a new Ruckus switch which hopefully will work and address my issues and frustration.

Hi @Tpad 


Thank you for contacting RUCKUS Lennar Home Community.

Hope you are doing well!!!

Thank you for the information you shared.

As per the case description, I could understand that your RUCKUS setup is not working, and Access Points do not have power.

Could you please let me know the answers to the below query to assist you better?

On your switch while it's plugged into the outlet, do you see any lights on? (Amber or green) Please let us know which lights are on. (Please refer to the below picture and share a picture of the same, showing the light status and the FULL Switch panel cable connections to the Switch ports)

Please help us with pictures of your ICX-7150-C12P Switch showing the status of the lights and cable connections to the Switch ports.

Before uploading the photos please log in to the RUCKUS account and you can upload the image.

Please let us know the answers to the above query or let us know if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.




Hello Imran,

hope you are well.

I have tried to reset the switch approximately 20 time’s following instructions provided by you and your colleagues but it doesn’t work. The Status lights and light’s POE connected to APs do not light up and APs remain off. It is frustrating and it makes it worse that we have to get support through community chats rather than over the phone or in-person service. I have a few pictures of switch with only some lights in.