Showing results for 
Search instead for 
Did you mean: 

Power outage and currently not providing power to Access Points

New Contributor


I am in the same boat as some other that had a power outage due to a storm. I have tried the troubleshooting and I am still not able to access my switch to troubleshoot or get power back to my AP's in my house.

I have tried to SSH into it and it is not seen. I have tried a factory restore and it looks to be stuck as all the lights are amber still after a few hours. Items I do have is a USB A to USB C cable and no luck trying to access it. 

While I appreciate the help from the other posts, I do need assistance with doing the troubleshooting on a Mac. I do not have access to a windows computer to do most of the troubleshooting that I have seen on this forum.  

Any assistance would be beneficial and if I could actually talk to someone, this would be a lot smoother than waiting for a response. 



Hi @normiihack 

Hope you are doing well

I will add the console Access to the switch ICX-7150 ( white box in your closet ) using a Mac computer to the existing  guide: 

1-First at all you need to install the drivers to read the cable type C to console the switch in your Mac computer. 



2-After successfully installing the Mac Drivers, open the Mac terminal, when you see the command prompt do the following:

Enter this command:

ls /dev/cu.*

This command will display something like this:

One of those logs will say something similar to /dev/cu.SiLabs_Serial (which is related to the drivers you installed)

3-Then enter the following command using the name of the installed driver that was displayed:

screen /dev/cu.SiLabs_Serial 9600

4-Hit Enter and you will have access to the ICX7150’s CLI.  (Comand Line)

Video link as reference:

Here we have to scenarios if you get the following prompt 

ICX7150-C12 Switch>

That means that we need to check the PoE ( Power over Ethernet ) Please run the following commands 

ICX7150-C12 Switch>show inline power detail

ICX7150-C12 Switch>show inline power 

ICX7150-C12 Switch>show version 

Copy and paste here to analyze.

Or if you get the following prompt:


You can try to boot up from primary image/secondary

boot_primary or boot_secondary

If that does not work we need to preform a software recovery :

This process can be done also in a Mac computer, link:

Best Regards