Showing results for 
Search instead for 
Did you mean: 

Power outage, SWITCH light amber and green, unresponsive ICX 7150

New Contributor

My switch is stuck in stand by mode. - I followed these steps but my switch is not alive at the end so I am not able to recover it either. Also some ports on the switch are damaged which is causing wiring damage for me. Please send new replacement switch.



Hi @AliParacha 


Thank you for contacting RUCKUS Lennar Home Community.

Hope you are doing well!!!

Thank you for the information you shared.

As per the case description, I could understand that your RUCKUS setup is not working, the Switch is stuck on boot mode with an Amber and Green light.

As you mentioned there are lights on PWR and SYST, if there is an amber/orange light on the "SYST" and a green light on the "PWR" on the Switch (as it is in the below picture). Meaning the Switch is stuck in the boot mode.

Basically, due to the power outage/ power spike, the switch went to a state that we call ‘boot mode’ that is not able to boot up properly. 

Please follow the below steps to fix this issue:

First, we will try to reset the Switch as described below:

1. Please try to disconnect from the Power outlet the ICX-7150 and reconnect.

2. Please try to press the reset button using a paper click or a small stick 

  • Remove power from the switch.
  • Press and hold the Reset button while applying power to the switch.
  • After all the system LEDs flash amber, release the Reset button.

Below is the Guide and Videos link for your reference:

Video link:



IF RESET DOESN’T WORK: Please follow the below steps. (As you have already shared the link)

If the reset does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

Below is the Guide and Video Link to perform the Software recovery process:

Please refer to the below guide and Video link:

Video Link:

If you have already tried software recovery as explained in the above guide, please share us a pictures of the cable connection you have connected between your Switch and the Laptop. Also share the screenshots of the error you are getting when performing software recovery steps.

Please let me know if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

Hi Imran,

This problem has been going on for the past few months. To circle back real quick, the Amber and Green lights are on as you have described. I had also tried the first step many times in the past with little success since it would not always work. This time around It was so bad that I was without internet for a week so I had no choice but to perform a software recovery. 

Since the software recovery did not work, I had to go back and reset the switch multiple times again like I had done in the past and it finally started working again. Although I know for a fact when there is a power outage or power interruption of any sorts the switch will revert back to boot mode like it has been doing for the past few months. 

Furthermore, In order to share the pictures with you of the switch connected with both the ethernet and USB cables I will have to unplug my switch, which I am unwilling to do because everything is working fine right now, and plug it with my computer risking it going into boot mode again.

In the future though when it goes into boot mode I can plug it in then and show you the pictures but I use internet daily and can not go without internet for another week like I had to last time around.

Either sent me the RMA now or we will have to wait for it to go into boot mode before I can perform a software recovery and send those pictures to you. 

Thank you! 


Hi @AliParacha 


Thank you for the update and the detailed information you shared.

Please note, Switch will get stuck on boot mode usually when the RUCKUS ICX-7150-C12P Switch is on an older version. So, we suggest you Upgrade your Switch to the latest stable version to avoid this issue in the future.

To check your current version and assist you accordingly with the Upgrade, please help us with the output of the commands by following the below process. 

Please follow the below steps and help us with the queries,

1. To check this issue, we must identify the ‘current’ IP address assigned by your local router to the switch ICX-7150-C12P

I will leave you a guide on how to perform an IP scanner on your local network to identify the switch IP address very easily. 

How to find my Ruckus “Devices IP address” using free applications:

2. Once we identify the IP address of the switch proceed to access remotely to the device “Command Line” 

How to remotely access to 'ICX 7150-C12P' or 'access points' "Network devices":

If you can access the Command line should look like this:

ICX7150-C12 Router> OR

ICX7150-C12 Switch>

Please enter the below commands once you log in to CLI and share the output.

Note: Hit Enter to accept each command 


show version

show flash

Please share the output of the above commands or share the screenshots if stuck at any step or error (if any) and let me know if you have any queries in this regard.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

New Contributor


I am having the same problem.  After the power outage I have a yellow and green light.  There is no power being run to my ceiling units.  I factory reset the unit and got the blinking yellow lights.  Then I tried to find the config wifi signal to connect to but it's not available.  I also tried visiting the IP address that my neighbor gave me but the page didn't load.  I downloaded Lanscan and scanned for the Rukus IP but it didn't find anything.  I'm stuck can someone help me?