Showing results for 
Search instead for 
Did you mean: 

My ICX7150 switch stuck in router mode

New Contributor

My Ruckus ICX7150-C12P has never worked properly. Switch stuck in router mode, confirmed Switch listed as router on ISP device table. Unable to Telent to flash image. Problem confirmed to be hardware. Problem has existed since new as unstable. Fiber WiFi provider checked everything and replaced modem as we thought that was the issue. Everything works up to the modem. Bypassing Ruckus (disconnecting from modem)results in stable wifi. Reconnect Ruckus with hard CAT line starts with excellent speed download/upload but 5 seconds later, all gone. Zero download/upload. Does not change after that. IT specialist (hired by me) worked 3 hours and confirmed problem. He states Ruckus has a hardware problem, not a software or connection problem. He advised the unit needs to be replaced and is a common problem with this unit



Hi @Warriorpilot 


Thank you for contacting RUCKUS Lennar Home Community.

I hope you are doing well!!!

Thank you for the information you shared.

As per the case description, I understand that your RUCKUS setup is not working, as the RUCKUS ICX-7150-C12P Switch is stuck in router mode.

Router code issue can be resolved troubleshooting steps, please help me with the below queries to assist you resolving this issue.

Please follow the below steps and help us with the queries:

1. To check this issue, we must identify the ‘current’ IP address assigned by your local router to the switch ICX-7150-C12P

I will leave you a guide on how to perform an IP scanner on your local network to identify the switch IP address very easily. 

How to find my Ruckus “Devices IP address” using free applications:

2. Once we identify the IP address of the switch proceed to access remotely to the device “Command Line” 

How to remotely access to 'ICX 7150-C12P' or 'access points' "Network devices":

If you can access the Command line should look like this:

ICX7150-C12 Router> OR

ICX7150-C12 Switch>

Please enter the below commands once you log in to CLI and share the output.

Note: Hit Enter to accept each command 


show version

show flash

Please share the output of the above commands or share the screenshots if stuck at any step or error (if any) and let me know if you have any queries in this regard.

Thank you again for your patience.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

I've used SSH to access the CLI.  Entering the "enable" command works and the prompt changes from "ruckus>" to "ruchus#.

However when I enter the "show version" or "show flash" commands I get a message stating the command is either unrecognized or incomplete.  Typing "show ?" displays all the available options and neither "version" or "flash" are listed.

Please advise.  Thank you.

Hi @Warriorpilot 


Thank you for the response and the information you shared.

The ‘ruckus>’ prompt you are seeing on the CLI is of Unleashed and not of the ICX-7150-C12P Switch.

You should see the Switch Dashboard as shown in the below screenshot to confirm it’s a Switch IP Address. 

Please check the other IP Addresses from the IP scan results, by the name of Ruckus Wireless or Brocade Communications to confirm the IP address of the Switch and access the CLI.

Please let me know if you have any queries in this regard.

Thank you again for your patience and understanding


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

Screen Shot 2023-12-07 at 1.48.02 PM.pngScreen Shot 2023-12-07 at 1.48.20 PM.pngThank you...yes you were right, I was logging into the AP and not the switch.  Got the correct IP now but can't login.  I've tried the super:sp-admin but it won't work.  I even factory reset the switch and still can't login.  Also, cannot connect via SSH - says connection refused.