Showing results for 
Search instead for 
Did you mean: 

ICX 7150 Switch Rebooting Constantly

New Contributor II

As of this morning, my switch is rebooting constantly. Every 15-30 minutes. I called Ruckus support and they directed me to this forum. Please assist me with troubleshooting.

I saw several other posts regarding this same issue, but do not see how/if this was resolved. I tried to follow the instructions provided by Imran on ‎this post at ‎07-21-2023 09:15 AM so that I could provide more information, but I ran into some issues. I could not connect via IP as the connection was timing out, this is definitely the IP for the switch as I confirmed it on the Comcast router's connection table.

I was eventually able to connect with a USB serial connection, but could not run the commands that Imran suggested to the other user as the Putty session is constantly being flooded with information on what the switch is doing. I have a complete export of the Putty session log that shows what the switch was doing from the time I connected, it rebooted, came back online, and then rebooted again. I do not see a way to upload an attachment, only pictures. If there is a way I can provide this log, please let me know.

SSH Connection FailureSSH Connection Failure

After reboot is completeAfter reboot is completeDuring RebootDuring Reboot


Hi @Aaron 

Thank you for the response and the information you shared. 

This issue is because your switch is running on the Routing code (SPR). The Switch should run on the Switching code (SPS) to avoid these issues for Lennar home users. Due to a power outage/power spike, the Switch boots up on the other partition which may be running on a ‘Routing Code’ results in causing this issue.

As I can see from the output you shared, your Switch is booted up on the secondary partition which is running on Routing code (SPR) as highlighted in the below screenshot. 

Please Enter the below commands in CLI to fix this issue:

Note: Hit Enter to accept each command 


copy flash flash secondary 

boot system flash secondary yes 



ICX7150-24P Router>enable (hit enter to accept the command) 
ICX7150-24P Router#copy flash flash secondary (hit enter to accept the command and wait: until the flash finished) 
ICX7150-24P Router#boot system flash secondary yes (hit enter to accept the command: the switch will reboot)


We suggest upgrading your switch to the latest stable version to avoid this issue in the future. Your Switch is on an older version that is 08080d. Please let us know once you complete the above process to assist you with the Upgrade of the Switch.

Please let me know if you have any queries in this regard.

NOTE: Please feel free to mark the post as ACCEPTED SOLUTIONS.

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

View solution in original post

New Contributor II

I successfully upgraded the firmware on the switch to version SPS08095m. Console output for show version and show flash is below. Currently waiting to see if the issue persists before calling this resolved.

Latest stable firmware version downloaded here. Had to upgrade to 08.0.90mc first. Then upgraded to 08.0.95m.

Followed upgrade instructions here.

Obtained TFTP server software here.

No password has been assigned yet...
telnet@ICX7150-C12-Switch#show version
Copyright (c) Ruckus Networks, Inc. All rights reserved.
UNIT 1: compiled on Aug 8 2023 at 22:55:03 labeled as SPS08095m
(31457280 bytes) from Primary SPS08095m.bin (UFI)
SW: Version 08.0.95mT211
Compressed Primary Boot Code size = 786944, Version:10.1.26T225 (mnz10126)
Compiled on Tue Nov 29 12:43:26 2022

HW: Stackable ICX7150-C12-POE
UNIT 1: SL 1: ICX7150-C12-2X1G POE 12-port Management Module
Serial #:FEK3845Q2MV
Software Package: BASE_SOFT_PACKAGE
Current License: 2X1G
P-ASIC 0: type B160, rev 11 Chip BCM56160_B0
UNIT 1: SL 2: ICX7150-2X1GC 2-port 2G Module
UNIT 1: SL 3: ICX7150-2X10GF 2-port 20G Module
1000 MHz ARM processor ARMv7 88 MHz bus
8 MB boot flash memory
2 GB code flash memory
STACKID 1 system uptime is 12 minute(s) 40 second(s)
The system started at 05:34:08 GMT+00 Fri Dec 01 2023

The system : started=cold starttelnet@ICX7150-C12-Switch#show flash
Stack unit 1:
NAND Type: Micron NAND 2GiB (x 1)
Compressed Pri Code size = 31457280, Version:08.0.95mT211 (SPS08095m.bin)
Compressed Sec Code size = 29360128, Version:08.0.90mT211 (SPS08090mc.bin)
Compressed Pri Boot Code size = 786944, Version:10.1.26T225 (mnz10126)
Compressed Sec Boot Code size = 786944, Version:10.1.14T225 (mnz10114)
Code Flash Free Space = 1032470528

View solution in original post


Hi @Aaron 

Greetings of the day!!!

Thank you for the response and update.

Great!!! It's good to know that the issue is now resolved. 

We appreciate your time and patience on this case.

NOTE: Please feel free to mark the troubleshooting post as ACCEPTED SOLUTIONS.

Thank you again for contacting RUCKUS Lennar Home Community and feel free to contact us for future queries.

Have a great day ahead!!!


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.