Showing results for 
Search instead for 
Did you mean: 

Have a 7150 switch w/APs that failed to power up after power outage.

New Contributor

Spoke with a representative 10 days ago (Chris Duffield) who initiated an RMA for a 7150 switch. I've had no communication since, and have not received the new switch. Attempting to determine the status. Just opened a new case (01404705), but response instructed me to post in this forum.



Hi @aw0911 ! 

Hope you are doing well ! 

Effective November’2022, ‘Ruckus Support for Lennar Homes customers will no longer be handled by phone or email. We will be exclusively supporting customers via this community forum support model.

Basically, as there is no support by phone or email at this time, you have to go to the Forum as you did and  created a post , I will be sharing some  steps to do the necessary troubleshooting to determine if it needs replacement, once you confirm, I will be sharing the next steps 

1- Does the ICX-7150 C12p switch have any lights on? like the yellow system light or similar while you have the unit plugged into the outlet?


2- Have you tried another power source or outlet to rule out any outlet issues?

Best Regards 

Fernando Vasquez 

Thanks for the response. The green power light and the yellow SYST lights on the switch are on, but no power to the APs. The prior phone rep did some diagnostics and said the switch needed to be replaced.

Hi @aw0911 


Basically, due the power outage the switch went to a state that we called (boot-mode) that is not able to boot up properly. 

That does not mean is broken or need to be replace 'in some cases'

1-Please try to disconnect from the Power outlet the ICX-7150 and reconnected.

2-Please try to press the reset button using a paper click or a small stick 

  1. Remove power from the switch.
  2. Press and hold the Reset button while applying power to the switch.
  3. After all the system LEDs flash amber, release the Reset button.

Video link :

If that does not make any difference, we need to perform a software recovery since it can be that the image flash is corrupted so in basic words the unit is not able to boot up properly and need re-install the image to boot up properly.

3-We need to access (physical) using one of the cable to the ICX-7150C12P mentioned on the below guide: 

How to console in the ICX-7150-12cp

Once we are there, we can try to boot up the unit using the following commands: 

Boot_primary or Boot_secondary 

If that step does not work Software recovery needs to be applied

Here is the guide:

Best Regards 

Fernando Vasquez 


I have rebooted the switch several times, and also tried a reset, but there was no change. Still no power to the APs. Unfortunately the software recovery that you describe is beyond my technical abilities, and exceeds the time I am willing to spend on this. Since Ruckus is apparently unwilling to replace the switch and no longer offers phone support to Lennar customers, I will be forced to buy another switch (from another company). Thank you for your help, but unfortunately this support did not resolve the problem.