Showing results for 
Search instead for 
Did you mean: 

Faulty equipment, need an RMA

New Contributor

No internet or wifi starting 3 AM this morning. I unplugged the Ruckus ICX-7150-C12P and am able to connect hardwired to the internet. If I plug it back in I lose the hardwired connection and still no wifi.


I've done as instructed. Same green lights on the switch but now the AP has a red light at PWR. 

As I hit send the PWR turned green, then the rest did as well. 

If all the lights show it should be working correctly. Might it need a firmware update? If so, I don't know how to do that.

Hi @BillRamos 

Thank you for the response and the update.

Yes, you can upgrade the Switch and the Access Points.

However, before that could you please confirm if everything is now working as before?

Thank you again for your patience and understanding.


Best regards,

Imran Sanadi

RUCKUS Lennar Home Community.

No, still not working. Green lights on everything but no wifi.

If I leave the switch plugged in I have no hardwire connection.