Showing results for 
Search instead for 
Did you mean: 

AP R510 won’t turn on

New Contributor

I have two AP R510 devices that won’t power on after inclement weather caused power to be lost for a couple hours. 

Still getting WiFi through my router and ICX 7150-C12P switch is still getting power (PWR light is green, SYST light is amber). I’ve tried power cycling the router but no joy. 

Not sure what to do next. 



Hi @Silver_six 


Greetings of the day,


Based on your description your switch has one green and one yellow light, it means that the switch is stuck in boot mode.


Please try to perform the factory reset process again ( sometimes needs to be done multiple time) and let us know the result.


1-Please try to disconnect from the Power outlet the ICX- 7150 and reconnect it.

2-Please try to press the reset button using a paper click or a small stick 

  1.  Remove power from the switch.
  2. Press and hold the Reset button while applying power to the switch.
  3. After all the system LEDs flash amber, release the Reset button.

Video link:


If the resetting process doesn't work, we need to perform a software recovery.


Here is the quick guide to perform software recovery.


How to perform a Software recovery on an ICX7150 switch


Ruckus ICX Recovery Load boot code from boot monitor


Note: after fixing the issue of the Switch been stuck in boot mode, please perform an upgrade to the code 08095g UFI and upgrade both partitions with the switching code file named SPS08095gufi.bin, so perform the software recovery using the code 08090k with the upgrade image file named SPS08090k.bin, then when the switch is back to normal upgrade to the file SPS08095gufi.bin for both partitions primary and secondary.


1.Upgrade a Switch ICX-7150-C12P using a USB flash drive


2. Upgrade a Switch ICX7150-C12P via TFTP


3. Upgrade a switch via Web GUI (ICX7150 Switch)


Please let us know if you have any queries in this regard.


Best regards,


Lennar Home Community

It took me a while to get the all that. The AP R510 devices still have no power. 

Hi @Silver_six 


Thanks for your response.


Please let us know whether you have tried performing factory reset and the software recovery process or not.


If you find any difficulties in following the steps please share the screenshot of the error you are getting while following the steps.


Please let us know if you have any queries in this regard.



Best regards,


Lennar Home Community