Showing results for 
Search instead for 
Did you mean: 

How to properly enable Bonjour Gateway for Ruckus Cloud APs for casting?

New Contributor

We have multiple different VLANs but we are trying to dedicate one VLAN for casting. I have already created the Firewall policies/routes and traffic passes between the subnets and I have enabled a Bonjour Gateway on the Ruckus AP but still unable to cast (Currently testing for Chromecast but need it working for Airplay as well). Casting works just fine if they're on the same VLAN obviously. 

This is what my Bonjour Gateway looks like:

I have toggled "Directed Multicast" to try to assist but it didn't work. This is a setting on the AP itself


RUCKUS Team Member

Hi, your screenshots appear to be from SmartZone, can you confirm that you are trying to configure it on Ruckus Cloud?

Anyway, bonjour must be enabled by Access Point.

In Ruckus Cloud: To reach the AP Bonjour Services page, click APs on the menu, and then click an AP name. When the AP information page appears, locate the Settings box in the bottom-right corner of the page, and then click Edit. The AP Bonjour Services page appears.

In SmartZone: Edit the desired access point, then go to advanced options -> Toggle Bonjour Gateway -> select your bonjour policy (you can create the policy in Service -> Bonjour).

Bruno Andrade | Principal TSE Bulldog Americas | RCNA | CWNA | CWDP
Follow me on LinkedIn

Thank you, I have done this but it is still not working unfortunately. I am unsure what else to do. The only thing in between is a Watchguard Firewall and a Juniper Switch. I have allowed traffic to flow between the subnets and I can ping just fine so what else can I do?

Have you selected the Chromecast service in bonjour configuration?

Can you please share your AP bonjour configuration?



Bruno Andrade | Principal TSE Bulldog Americas | RCNA | CWNA | CWDP
Follow me on LinkedIn




I had sent the screenshot of my Chromecast being selected in the main post:


Here is this as well for the policy details:

Policy selected and enabled in AP config: