Showing results for 
Search instead for 
Did you mean: 

illegal class reported by PD

New Contributor II


I've connected some (17) Ubiquiti WAPs to an ICX7150-ZP48.

some WAPs arent loading (all connected with direct patch cables in the lab).

it seems to be randomly not always the same WAP.

"sh inline power" output shows this error"

illegal class reported by PD

all WAP are the same model (ubiquitin AC-Lite) and have the same firmware.

it doesn't seem that the switch has any power capacity issues.

I've tried different POE configurations:

"inline power power-limit 8000" (up to 20000)

"inline power power-by-clas 3" (and 4)

and just "inline power"

the switch version is SPS08095d and the POE firmware is 02.1.8 Build 004.

any idea what happing here?



New Contributor II

Thanks, Ben

you can see that all other WAPs are loading properly,

if the issue was with WAP requirements, wouldn't it happened with all WAPs (which are from the same model and firmware) and permanently?

In my case, it seems to happen arbitrarily on different WAPs.

is there a way of adjusting the POE parameters on the switch side?
other than what I've mentioned previously?


Generally speaking, the behavior should be consistent. With that said, our default configs would allow plenty of wattage and the AP should only draw what it needs. You can change the power settings, but it really only changes the allocation, not delivery method. I would still recommend checking with the vendor as I do think those APs need passive POE. 

Example of changing power limits to 15w:

conf t

int eth 1/1/1

inline power power-limit 15000

Ben Beck, RCNA, RCNI, Principal Technical Support Engineer

New Contributor II


got it.

ill check with them.

I've already tried different power allocation configuration, limits and by-class.


New Contributor III

Are you using identical patch cables for all of the WAPs? Are they 4-pair cables? Note that the UAP-AC-Lite only supports 802.3af 'Mode A', although that really shouldn't be a problem.


thanks for responding,

I've tried different patch cables, all of them are CAT6 cables. 

the thing is that It was not consistent and happened only with the ICX-ZP48 while I've never seen this issue with the ICX-48p, both with the same ICX firmware SPS08095d POE 02.1.8 Build 004.

I did try older firmware as well.

I'm going to test it again this week, is there any other information should collect?