Showing results for 
Search instead for 
Did you mean: 

Ruckus ICX 7150-C12P not working

New Contributor

Dear Sir/Madam,

My ruckus switch stopped working since yesterday and I have tried to do multiple resets to no avail. Even did a sequential reset of my modem and then the ruckus switch but the switch always boots up and is stuck at amber light and does not go to green.

Could you please help me on how to resolve this?



RUCKUS Team Member

Hi id,

Thank you for posting you query !!!

I understand Ruckus ICX 7150-C12P is not working and you have already tried multiple reset but the issue remains the same and it the stuck at amber light.

Could you please try to take the console access of the unit and try a software recovery as shown in the below link:

You can also refer the below short video for your reference for software recovery:

NOTE: Before you try software recovery once try to boot the switch from secondary flash using below command from boot OS and check if the unit is booting up or still stuck in boot mode.

ICX7150_boot> boot_secondary

If the issue is not resolved by software recovery the next step will be RMA

Please log a ticket with the below link so that we will help you to process RMA

NOTE: Please confirm us if you are from Lennar homes

I hope this information helps you

Please feel free to leave us a message if any concerns