cancel
Showing results for 
Search instead for 
Did you mean: 

No ping between cisco C9300 and ICX-8200 switch

Mohammadsaeed
New Contributor

Hi,

I have ICX-8200 switch link with cisco C9300 as trunk link but I can't ping between switches without make switch port native vlan 12 in cisco, and I don't want to use vlan 12 as native i want vlan 1

C9300 (port Gig1/0/1 ------> ICX-8200 (port 1/2/1)

here is my ICX8200 config:

vlan 1 by port
untagged ethe 1/2/1 
spanning-tree 802-1w
!
vlan 12 name Network_Mgt by port
untagged ethe 1/2/1
spanning-tree 802-1w

!
ip route 0.0.0.0/0 10.25.60.100
!
!
fast port-span exclude ethe 1/2/1
hostname ICX8200-8P-200
ip multicast passive
ip tftp blocksize 8192
fdp run

!
interface management 1
!
interface ethernet 1/2/1
no cdp enable
spanning-tree 802-1w admin-edge-port
pvst-mode
!
interface ve 1
!
interface ve 12
ip address 10.25.61.135 255.255.254.0
!
interface ve 4000

 

Cisco Switch:

interface GigabitEthernet1/0/1
description *** Connected to ICX8200-8P ***
switchport trunk allowed vlan 1,9,12,14,22,131,132,202
switchport mode trunk
udld port aggressive
no vtp
spanning-tree portfast trunk
end

interface Vlan12
ip address 10.25.61.36 255.255.254.0
end

 

using these configuration no ping between cisco and ICX switch, but if i add this command under cisco switch:

switchport trunk native vlan 12

Then i can ping but I don't want to use vlan 12 as Native, i want vlan 1 only.

 

Any help please

 

Thanks

 

2 REPLIES 2

jdryan
RUCKUS Team Member

Hi Mohammadsaeed, 

Could you try the below and give it a shot  : 
interface GigabitEthernet1/0/1
description *** Connected to ICX8200-8P ***
switchport trunk allowed vlan 1,9,12,14,22,131,132,202
switchport trunk native  vlan 1
switchport mode trunk

udld port aggressive
no vtp
spanning-tree portfast trunk
end

 

and on the 8200 :

Conf t 
vlan 1 
untagged eth 1/2/1 
vlan 12
tagged eth 1/2/1 

 

If the requirement here is to not have native vlan at all, then with the current config on Cisco as it is. 
Try the below on the 8200 : 

Conf t 
vlan 1 
tagged eth 1/2/1 
vlan 12
tagged eth 1/2/1
exit

Let us know if that helps !

- Ryan

inphobia
New Contributor III

bottom line is that with the current config your vlan headers are mismatched.

most cisco devices accept untagged packets on trunks by default, and they also have "switchport trunk native vlan 1" by default. since you untagged vlan 12 on eth 1/2/1 on the ruckus side it will be accepted by the cisco device & put on the native vlan. also, there's nothing wrong with using "switchport trunk native vlan 12" in this case. we use this for provisioning devices for example, so when they have no config they get put in a configuration vlan & when they get a config with vlan & reboot they continue to work.

tbh, i find it much more interesting in how the icx allows 2 different vlans to be untagged on the same port (as per your example). sounds like a flooding issue waiting to happen.